Home Nostruktor 13 ich kriege eine Krise

  • Hallo Cetz


    also heisst es die textur ID´s alle neu reinschreiben? Oh je das sind ja so viele... was das komische ist bis Freitag hat HN immer eigenen Projekte aufgemacht bzw bis Donnerstag hat nie probleme gemacht, seit dem ich am Donnerstag das EEP 13 Update und das Plugin installiert hab kommt das.

    Was ich vermute... es gab auch ein Windows Update am Donnerstag was ich installiert hab... nicht dass das damit zu tun hat...

    Ich kann versuchen die textur ID´s aus der TXT Datei rauszukopieren und in die neue Texturen Datei einfügen - das wäre die erste Methode oder ich werde die ganzen Id´s noch mal per Hand eintragen


    Ich hab versucht vorhin ein altes Projekt aus dem HN8 zu laden (was der HN13 davor ohne probleme gemacht hat) macht er jetzt auch nicht mehr.... egal welches Projekt man aufmachen will - Absturz (das kann eigentlich nicht mit dem Textur ID´s zusammen liegen oder? Wenn ich eins von HN8 aufmachen will dann muss er zumindest ohne Texturen aufmachen (also grau) so hat er mir das davor immer aufgemacht.


    Ich grübel schon die ganze Zeit was da nicht ok ist sein kann an dem Programm und komme nicht drauf.... die zwei Sachen die mir aufgefallen sind sind halt die beiden Updates am Donnerstag (EEP Update und Windows 7 Update) davor lief es immer ich konnte alle Projekte öffnen


    Hoffe das eintragen der Textur ID´s hilft und wenn nicht dann weiss ich auch nicht mehr weiter :aj_1:


    Gruß
    EEPFan36

    Asus Intel Core i7 4770, 3,40Ghz 8 GB RAM, 120 GB SSD, 1 GB HDD
    Win 7 Pro 64 Bit
    GForce Nvidia GTX 1060 6 GB RAM


    EEP 4, 6, 7.5, 9.1 Expert, 10.2 Expert und 11 Expert, 12 Expert, 13 Expert, HomeNos 8, HomeNos13 und Nostruktor für EEP 6, Höhen Explorer, Modellkonverter :thumbsup_1:

  • Wenn Du willst kannst Du mir mal ein paar Deiner Projekte ud vor allem die Texturen.txt zuschicken.

    Falls beides bei mir funktioniert, könnte man zumindest diese Fehler ausschließen,


    Ggf. finde ich ja auch den Fehler (wenn es ihn denn gibt) ind der Texturen.txt.

  • Hallo

    jetzt klappt es mit dem Texturen hab mich damit auseinander gesetzt.. :)


    Ich hab aber eine andere Frage zu HomeNos 3 und zwar... wenn ich Glasflächen reinlade zb Geländer mit Glasfronten dann ist zwar das Glas durchsichtig aber man kann durch das Haus durchschauen... hab schon versucht mit den Einstellungen rumzuspielen und verschiedene Einstellungen zu machen (hat bei einer Sache auch gut geklappt) aber hab vergessen mir das aufzuschreiben :am_1:

    Was muss ich da genau einstellen dass man das Glas sieht (dass es Glas ist) und nicht durch das Haus durchschauen kann


    Hab in letzter Zeit um die 50 Häuser gebaut und die machen sich echt gut in EEP 13 :an_1: bin echt zufrieden nur mit dem Glas das klappt nicht so ganz.. das wollte ich nur wissen


    Wünsche Allen hier einen schönen und ruhigen Freitag


    EEPFan36


    Ps

    Ich habe vor die Bilder meiner erstellen Häuser auf meine Seite zu laden damit Ihr euch das anschauen könnt und vielleicht auch was dazu schreiben könnt oder auch mal eine Bewertung oder Voting abgeben aber sobald ich die Seite fertig habe werde ich hier ein Link reinsetzen

    Asus Intel Core i7 4770, 3,40Ghz 8 GB RAM, 120 GB SSD, 1 GB HDD
    Win 7 Pro 64 Bit
    GForce Nvidia GTX 1060 6 GB RAM


    EEP 4, 6, 7.5, 9.1 Expert, 10.2 Expert und 11 Expert, 12 Expert, 13 Expert, HomeNos 8, HomeNos13 und Nostruktor für EEP 6, Höhen Explorer, Modellkonverter :thumbsup_1:

  • wenn ich Glasflächen reinlade zb Geländer mit Glasfronten dann ist zwar das Glas durchsichtig aber man kann durch das Haus durchschauen

    Das könnte unter anderem daran liegen, dass deine Hauswände nur eine Außen-, aber keine Innenseite haben.

  • Hallo

    also ich erstelle die Flächen im Blender nicht im HomeNos also keine Plane nehmen sondern ein Cube im Blender und dann als doppelverglasung machen (also aussen und innen Glas) ich habe eine Plane mit Glas Textur versehen und dann im HomeNos in den Einstellungen was eingestellt und da wurde das richtig dargestellt muss meine alte Datei wieder rausgraben und die Einstellungen schauen (weiss nicht ob das das mit keine+Vorderseite und dann Doppelseitig rechts war) hab heute Netz gemacht und hab diese Einstellungen genommen und da wird das Netz richtig dargestellt ich werde die Einstellungen mit der Glasfront noch mal testen...


    Ich hab eine Frage noch and die Kons und zwar.. hab gesehen im EEP Shop da gibt es diese Wasserfälle mit dem animierten Wasser... ich brauche einen bestimmten Wasserfall für meine Anlage und wollte mir diesen erstellen nur weiss ich nicht wie ich das mit der animierten Wasser mache... könnte mir das jemand erklären?


    Gruß

    EEPFan36

    Asus Intel Core i7 4770, 3,40Ghz 8 GB RAM, 120 GB SSD, 1 GB HDD
    Win 7 Pro 64 Bit
    GForce Nvidia GTX 1060 6 GB RAM


    EEP 4, 6, 7.5, 9.1 Expert, 10.2 Expert und 11 Expert, 12 Expert, 13 Expert, HomeNos 8, HomeNos13 und Nostruktor für EEP 6, Höhen Explorer, Modellkonverter :thumbsup_1:

  • Das könnte unter anderem daran liegen, dass deine Hauswände nur eine Außen-, aber keine Innenseite haben.

    Was Götz meinte ist, dass Du egal ob im Blender oder im HN. Entweder eine zusätzliche innere Wand bauen musst bei der die Normalen genau umgedreht liegen, also nach innen.
    Hilfsweise kann man im HN in den Modelleinstellungen auch festlegen, dass kein Faceculling berechnet wird. Dann wird das Modell so dargestellt, dass Polygone von beiden Seiten sichtbar sind. Diese Einstellung sollte man dann aber möglichst für alle Objekte gleich wählen.
    Dann auch den Hinweis von Frank dringend beachten. In der Reihenfolge der Modelle müssen Glasflächen immer als letzte eingesetzt werden.


    Gruß

    Dieter

    Schalten und walten ist mein Hobby, aber nur in EEP ;) 
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 8GB RAM, GT 850 von Nvidia, Windows 10 Home 64bit

  • Hallo EEPFan36,


    nicht nur du hast Probleme mit dem HomeNos. Ich selbst baue nun schon über 10 Jahre 3D-Modelle und hatte noch nie solche Probleme wie mit dem HomeNos13.

    Hier getätigte Aussagen der Kon's, das Abstürze des HomeNos durch Fehler des Benutzers hervorgerufen werden, muß ich doch widersprechen.

    Was macht der User falsch, wenn er z.B. eine DirectX-Datei eines Lampenmast mit 196 Polys und einer mit paint.net erstellten 128x128 Pixel großen DDS-Datei (natürlich mit einer in der Texturen.txt versehenen ID) in den HomeNos laden will und dieser dann abstürzt. Nach einem Neustart funktioniert es eventuell, manchmal braucht es auch 3 oder 4 Neustarts. Dann funktioniert aber alles, bis der HomeNos irgendwann mitten iim Programm wieder abstürzt. Mit viel Geduld und mehreren Abstürzen hat der HomeNos dann endlich ein im EEP verwendbares Modell erstellt.

    Ob ich die DirectX-Datei aus 3DSMax, AC3D, Blender oder einem anderen Programm erstelle, spielt für die Abstürze keine Rolle. Auch ob die Textur aus paint.net, PSP X6 oder einem anderen Programm stammt, hat mit den Abstüzen bestimmt nichts zu tun.

    Die Überprüfung meines Betriebsystems verlief erfolgreich, auch gab es keine fehlerhafte Einträge in der Registry.

    Seit über einem halben Jahr warte ich diebezüglich auf Antwort von Trend. Leider NULL.


    Wenn der HomeNos eine fehlerhafte DirectX- oder Textur-Datei erkennt, sollte er daraufhin nicht einfach abstürzen, sondern eine diesbezügliche Fehlermeldung bringen. Dies kann nach meinen bisherigen Erfahrungen aber schwierig sein, da er auch bei korrekten Dateien abstürzt.


    Gruß Schrauber

    WIN 10 Home 64bit --- PC: Intel I5 - 4460S 2.9GHz, 8GB RAM, GK Nvidea GTX 745 4 GB - EEP X, EEP 13 Patch4, HomeNos 13

  • Auahauahauaha,

    da habe ich scheinbar Glück mit meiner HN Installation.

    Ich arbeite mit C4D, exportiere von dort mit dem x-File Exporter und lade diese x-Files in 99,8% aller Fälle problemlos in meine Projekte.

    Meine Texturen speichere ich im tga-Format ab. Trage sie wie üblich in der Texturen.txt ein und wenn ich das alles getan habe bevor ich den HN starte, brauche ich mich beim Modellimport noch nicht einmal um die richtige Textur ID kümmern. Das wird bei dieser Form des Exports / Imports vom HN erkannt und richtig dargestellt.

    Fehlermeldungen sehe ich, wenn ich versuche ein Projekt zu laden /speichern, bei dem nicht alle Dateien den richtigen Namen haben (was man durch händisches Ändern einer Kopie des Projekts bewirken kann). Dann kommt die Meldung "zu viel Eis".

    Abstürze erlebe ich so gut wie nie, egal was ich bisher versucht habe.
    Was aber beim Import sicherlich zu Problemen führen kann ist die Tatsache, dass der HN ungerne mit Umlauten und Sonderzeichen zu tun hat.

    Der von C4D erzeugte Würfel wird z.B. vor dem Export in Wuerfel umbenannt etc.


    Gruß

    Dieter

    Schalten und walten ist mein Hobby, aber nur in EEP ;) 
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 8GB RAM, GT 850 von Nvidia, Windows 10 Home 64bit

  • Hallo Dieter,

    es liegt bei mir bestimmt nicht an falscher Namensgebung der Dateien. Ob nun DDS oder TGA-Dateien verwendet werden, sollte bestimmt auch nicht ausschlaggebend sein. Solche Fehler können schon mal passieren, aber eigentlich bin ich schon etwas zu lange dabei.


    Gestern habe ich eine neue Strassenlampe mit AC3D gebaut. Licht und Lichtkegel in gesonderten Dateien hinzugefügt. Der HomeNos ist beim Erstellen dieses Modell's (ca.500 Polys) mindestens 10 x abgestürzt. Heute habe ich aus diesen Dateien das gleiche Modell als 2 armige Lampe erweitert und der HomeNos lief problemlos. Gleiche Dateien (nur ein paar Polys mehr), gleiche Textur. Beim Projekt "Strassenlampe_einfach" gabs Probleme, bei "Strassenlampe_doppelt" nicht. Es liegt also nicht an den exportierten Dateien oder der Textur.


    Ein weiterer Hinweis darauf, dass es nicht an meinen Modellen liegt, ist, das mein HomeNos 13 auch bei den mitgelieferten Beispiel-Projekten ab und zu abstürzt.


    Gruß Schrauber

    WIN 10 Home 64bit --- PC: Intel I5 - 4460S 2.9GHz, 8GB RAM, GK Nvidea GTX 745 4 GB - EEP X, EEP 13 Patch4, HomeNos 13

  • Hallo Schrauber,


    ich habe keine Ahnung, woran die Abstürze bei Dir liegen. Ich konstruiere komplett im Home-Nostruktor 13 und habe vielleicht einen Absturz in den letzten vier Wochen gehabt. Man kann das Programm dann wohl als stabil bezeichnen.

    Bezüglich des Imports kann ich natürlich nichts sagen. Aber Texturen (ich verwende das .png-Format) werden problemlos übernommen - egal aus welcher Quelle. Das gleiche betrifft auch die Cubemaps.


    Eine Fehlerursache könntest Du noch ausschließen: Alle Projekte sollten direkt im Unterverzeichnis "Projects" angelegt sein, da es sonst u. U. zu Fehlern kommen kann.

  • Hallo Schrauber,

    was da bei dir schief läuft kann ich nicht sagen. Aber genau wie mein Namensvetter sehe ich den HN als stabil laufendes Tool an.


    Gruß

    Dieter

    Schalten und walten ist mein Hobby, aber nur in EEP ;) 
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 8GB RAM, GT 850 von Nvidia, Windows 10 Home 64bit

  • Hallo,


    gestern hatte ich zum ersten Mal keinen Absturz. Schon fast seltsam.


    Habe nun noch mal alle Ordner überprüft und keinen Fehler (Dateinamen, Texturen-ID, Texturen.txt, Projects-Ordner etc.) gefunden. Das es nicht an den von mir erstellten Dateien liegen kann, ergibt sich daraus, dass es trotz der vielen Abstürze irgendwann dann doch zu einem erfolgreichen Endergebnis kam, ohne das Änderungen vorgenommen wurden.


    Wenn es schon kurz nach dem Start des HomeNos13 zum Absturz kommt, wenn man gerade mal ein neues Projekt aufruft, den Projektnamen (z.B. 'Strassenlampe_einfach') und den Objektname (z.B. 'Mast') eingeben hat und auf die OK-Taste klickt, kann man eigentlich nicht viel falsch gemacht haben. Nach einem Neustart des HomeNos funktioniert es dann meistens.

    Während der Bearbeitung habe ich festgestellt, das die meisten Abstürze nach klicken auf die Objekt-Update-Taste oder Fenster-schliessen passieren.


    Wie schon gesagt konnte ich jedes Projekt ohne Änderungen nach etlichen Neustarts erfolgreich beenden.


    Gruß Schrauber

    WIN 10 Home 64bit --- PC: Intel I5 - 4460S 2.9GHz, 8GB RAM, GK Nvidea GTX 745 4 GB - EEP X, EEP 13 Patch4, HomeNos 13

  • Ich hab eine Frage noch and die Kons und zwar.. hab gesehen im EEP Shop da gibt es diese Wasserfälle mit dem animierten Wasser... ich brauche einen bestimmten Wasserfall für meine Anlage und wollte mir diesen erstellen nur weiss ich nicht wie ich das mit der animierten Wasser mache... könnte mir das jemand erklären?

    Sorry - habe es gerade erst gelesen. Am Besten stellst Du Fragen in einem neuen Thread, dann werden sie schneller gefunden.


    Schaue mal im Home-Nostructor-Wiki unter Interne ini / Wasser, dort findest Du eine Menge Infos. Ich hoffe, Du kommst damit zurecht. Wenn nicht - einfach nochmal fragen.

  • Hallo Serpentiner63


    danke Dir für den Link hab mir das angeschaut aber was ich meinte ist wie ich das im Blender erstellen kann zum übernehmen im HN... ich weiss ist eine schwierige Frage... das mit der Ini Datei und der Wasseranimation war auch meine Frage aber zuerst muss ich ja das Wasserfall an sich Modellieren in Blender und das wollte ich wissen was ich genau erstellen muss bzw ob das Wasser in Blender oder in HN erstellt werden muss


    Einen schönen Dienstag Abend

    EEPFan36

    Asus Intel Core i7 4770, 3,40Ghz 8 GB RAM, 120 GB SSD, 1 GB HDD
    Win 7 Pro 64 Bit
    GForce Nvidia GTX 1060 6 GB RAM


    EEP 4, 6, 7.5, 9.1 Expert, 10.2 Expert und 11 Expert, 12 Expert, 13 Expert, HomeNos 8, HomeNos13 und Nostruktor für EEP 6, Höhen Explorer, Modellkonverter :thumbsup_1: