Tunnel-Durchbruch-Textur Grafikfehler: Weisse Flecken

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
In the case of pictures that are attached to the article, the source must also be stated. This also applies to your own pictures, which were taken by you. Pictures without source information will be deleted!
  • Zu Beitrag 16 - jetzt eben mal gemacht

    [Blocked Image: http://up.picr.de/31343028lh.jpg]

    So weit das Auge reicht - vielleicht kommt es auch auf die Grafikkarte an ? Oder dessen Einstellung ? Ich kenne mich da nicht mit aus !


    LG Lothar

    EEP 6.1 / Konverter / EEP 13.2 , Plugin 1,2 / EEP 15.1 , Patch 2 , Plugin 1 / EEP 17.2 , Patch 1 , Plugin 1,2
    Win 7 pro 64 bit
    Asus H97M-Plus , i5-4690 3.5GHz , MSI R9 290X 4GB , Kingston HyperX Blue 16GB

  • Also wenn ich es so mache, kommt dieser Fehler tatsächlich, wenn man aber eine andere Textur wählt kommt er zwar auch aber lange nicht so stark, bin grad weiter am rumprobieren, der Sache kommen wir noch auf den Grund ...

    Einen Computer hat man, um damit Arbeiten zu erledigen, die man ohne Computer nicht hätte.

    EEP 16

    EEP 17

    Windows 10 Home

  • Ok, also es hängt eindeutig mit den Rasterpunkten zusammen, wenn man beim anlegen einer Anlage alle Werte immer gleich lässt und es einmal mit 500 Knotenpunkte probiert ist der Fehler sehr stark zu erkennen, wenn man dasselbe mit z.B. 40 Knotenpunkten macht ist von dem Fehler keine Spur zu sehen ...

    Dann kommt noch dazu , daß bei bestimmten Texturen der Fehler besser zu erkennen ist als bei anderen

    Einen Computer hat man, um damit Arbeiten zu erledigen, die man ohne Computer nicht hätte.

    EEP 16

    EEP 17

    Windows 10 Home

  • Hallo Zusammen

    Ich wollte eigentlich nur eine neue Idee für eine neue Anlage skizzieren, da hat's mich gleich wieder voll erwischt:

    BANG! :ah1: Die Standardtextur (nicht Tunnel) schlägt im Hintergrund auch Flecken in die Anlage. Auch hier ist mit 'Rückgängig' nichts mehr zu retten...

    Irgendwie wird die Helligkeit für den Horizont angepasst. Weil der aber eigentlich dunkel sein sollte, fällt es halt so deutlich auf.

    Man könnte nun sagen, dass alles was heller ist als die Grundhelligkeit der meistverwendeten Texturen, für die Verwendung in der Anlage tabu sein muss. Mmmh... :aw_1:

    Einfärben der Textur (z.B. schwarz) bringt auch nix.

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • Ich hatte es besonders auf der Ausbauanlage 3 und 4, erst nach dem Ändern der Bodentextur ging es so einigermaßen.

    Windows 10 Home
    Intel(R) Core(TM)i7-6700 CPU@ 3.40 GHz
    16 GB Ram
    Nvidia Geforce GTX 1060

    EEP 2., 6 , 9 , 10 ,11 ,12,14 ,15

  • Nochmals eine Info meinerseits

    Wenn ich im 2D-Modus mit der Standard-Textur etwa 20-30mal neu ansetze, mal etwas zurücksetzte und einfach vor mich her male, dann verabschiedet sich EEP mit einem unerwarteten Fehler. Diesen hatte ich auch schon vor längerer Zeit mal im Bug-Tracker gemeldet. Er ist immer noch da und ich könnte mir sogar vorstellen, dass hier eine Verknüpfung bestehen könnte:

    Wenn nämlich der Speicher am falschen Ort vollläuft, dann wird es EEP unweigerlich einmal zuviel (Stichwort: Memoryleak).

    Das ist natürlich wieder Kaffeesatzleserei, aber mich überrascht es schon, wenn solche krasse Bugs immer noch da sind.

    Nur so meine 2 Rappen...

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • Hallo Zusammen

    Heute konnte ich beim Texturieren folgende Erkenntnis gewinnen:

    Texturen in einem Bodenmotiv verhalten sich anders als eine einzeln aufgetragene Bodentexturen!!!

    Wird kein Bodenmotiv verwendet und diese Textur grossflächig im Bereich des Horizonts aufgetragen, so verschwinden die oben beschriebenen Flecken weitgehendst. Das ist auch der Effekt den Lothar (nohabs) uns weiter oben (Posting #41) gezeigt hat.

    Der Fehler liegt also in der Art, wie sich Texturen verhalten, wenn sie durch ein Bodenmotiv aufgetragen wurden. Man könnte das Bodenmotiv also einzeln nachzeichnen und gut ist...:ad_1:

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • Hallo Alexander

    :be_1:Richtig . Und damit kann man - wenn mans weiß wie EEP tickt - leben .

    LG Lothar:aq_1:

    EEP 6.1 / Konverter / EEP 13.2 , Plugin 1,2 / EEP 15.1 , Patch 2 , Plugin 1 / EEP 17.2 , Patch 1 , Plugin 1,2
    Win 7 pro 64 bit
    Asus H97M-Plus , i5-4690 3.5GHz , MSI R9 290X 4GB , Kingston HyperX Blue 16GB

  • Hallo Lothar

    Richtig: Leben kann man, aber man wird halt richtig alt dabei (noch älter) die Bodentexturen einzeln zu setzen.

    Ich hoffe schon, die Entwickler haben ein Gehör für dieses Problem. Auf jeden Fall ist er im Bug-Tracker gemeldet.

    Freundlicher Gruss

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • Hallo Zusammen

    Ich muss diesen alten Thread leider wieder aus der Versenkung holen, weil sich in der grundsätzlichen Behandlung von Texturen in EEP überhaupt nichts getan hat!!!

    Und ja, ich habe es schon vor Jahren und wiederholt hier im Forum und im Bug-Tracker gemeldet!

    Es ist wirklich ein grosser Show-Stopper, wenn man eine Anlage baut und plötzlich diese weissen Flecken erhält, aber seht doch bitte selbst:

    Anlage Nr. 131 -> unbeschadet

    Anlage Nr. 132 -> Ab hier kann sie nicht mehr verwendet werden!

    (Ich bin jetzt schon bei Nr. 212 ...)

    Ein Weg zurück habe ich nämlich noch nicht gefunden und es ist äusserst frustrierend, wenn man wochenlang an einer Anlage gearbeitet hat und plötzlich feststellt, dass die ANLAGE dadurch NICHT MEHR BRAUCHBAR ist!!!

    -> Ich werde unten noch einen neuen Eintrag erstellen, weil ich hier nur 3 Bilder hochladen kann.

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • Also nochmals und hallo zusammen

    Bei meinen Nachforschungen habe ich herausgefunden, dass die angelegten *.dds-Dateien plötzlich nur noch halb so gross sind:

    Anl_LX-B_20200228_0131_Test1AD.dds -> 10’923kB | 2048 x 4096

    Anl_LX-B_20200228_0132_Test1AD.dds -> 5’763kB | 2048 x 2048

    (Das untere Bild wird hier im Browser gerne grösser angezeigt als die Datei oben. Zum Hochladen wurde das Dateiformat jpg verwendet.)

    Ich entsinne mich, dass es in älteren Versionen manchmal geholfen hat, die *.dds-Dateien wegzuschmeissen und dann durch EEP neu anlegen zu lassen. In EEP16 gibt es diese Möglichkeit leider nicht mehr.

    Warum sich EEP so verhält, kann man als Benutzer natürlich nicht beurteilen und dieses Unvorhersehbare nimmt einem jeden Spass am Weiterbauen:

    Denn um zu prüfen ob die Anlage noch intakt ist, müsste man nämlich jedesmal nach dem Speichern die Anlage wieder laden und diesen Effekt ausschliessen!

    Ich habe für’s erste wieder einmal genug, weil wieder dermassen viel Zeit flöten gegangen ist!!!

    An die Entwickler: Gerne stelle ich meine Anlagen für die Fehlersuche zur Verfügung. Man kann mich ja hier erreichen...

    (-> Nachträgliche Anmerkung: Tunneldurchbrüche habe ich aktuell keine auf der Anlage...)

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

    Edited 3 times, last by LX-B (September 29, 2020 at 5:31 PM).

  • Hallo Paul

    Die *.dds-Dateien werden schon neu erstellt, aber der Fehler wird jedesmal neu eingerechnet!

    Also: Wenn Du Dir die 'Pest' eingefangen hast, dann wirst Du sie nicht wieder los!!! :ak_1:

    Freundlicher Gruss

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • Hallo Alexander LX-B,

    hast du mal versucht, die Anzahl der Bodentexturen zu reduzieren?

    Und dann die dds neu erstellen?

    :aq_1:

    eep_gogo ( RG3 )

    -------------------------

    Intel i3-540 3,2GHz 8GB, RAID10, HD 6570 1GB, W7/64 Prof., EEP 6-6.1, 10-17.0, HN13+15/16+15/16DEV, TM, "Schiefe Ebene 6 + 8", "Bahn2000", "Faszination der St. Gotthard-Nordrampe"

  • LX-B

    Hallo Alexander,

    diesen Fehler hatte schon mal ein User hier im Forum beschrieben.

    Lege mal eine andere Textur im Hintergrund an.

    Nehme dazu eine Textur mit möglichst wenig Muster, am besten einfarbig.

    Auch wenn Du für die Ansicht einen steileren Blickwinkel wählst müsste der Effekt verschwunden sein.

    Viele Grüße

    Karl Heinz

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

  • Insgesamt ist und bleibt das aber sehr störend. Auch mich hat das schon öfter betroffen und gestört, genauso wie der Perlenschnureffekt bei Oberleitungen. Da ist es doch gut, wenn gelegentlich mal freundlich darauf hingewiesen wird, dass das noch nicht erledigt ist. Aber eine Grundsatzdiskussion muss jetzt hier nicht folgen.

  • Hallo

    Der Effekt tritt auf sobald ein Tunneldurchbruch gemacht wird - oder ein " Loch " in die Oberfläche " geschnitten " wird .

    Auch hier zu lesen - schon etwas her : #16

    LG Lothar :aq_1:

    EEP 6.1 / Konverter / EEP 13.2 , Plugin 1,2 / EEP 15.1 , Patch 2 , Plugin 1 / EEP 17.2 , Patch 1 , Plugin 1,2
    Win 7 pro 64 bit
    Asus H97M-Plus , i5-4690 3.5GHz , MSI R9 290X 4GB , Kingston HyperX Blue 16GB

  • Hallo Zusammen

    Ich bin mal dem Ratschlag von Reinhold ( eep_gogo (RG3) ) und Karl Heinz ( Schmiermax ) gefolgt und hab es ausprobiert:

    • Die ganze Anlage wurde kastriert und alle Texturen wurden bis auf das Bodenmotiv Sommerwiese 1 ersetzt, beziehungsweise übermalen.
    • Danach habe ich die *.dds-Dateien weggeschmissen und die Anlage
      • geladen
      • gespeichert
      • wieder neu geladen

    Und siehe da: Die hässlichen weissen Flecken sind weg - aber auch jeder wesentliche Inhalt der Anlage... :ar_1:

    Dann habe ich auch versucht einzelne Texturen zu ersetzen, aber da war ich hingegen leider erfolglos...

    Wie Ihr aus den Texturbildern oben entnehmen könnt, wurden auf dieser Anlage nicht massig unterschiedliche Texturen verwendet.

    Wenn man kaum ein dutzend Texturen verwenden kann, dann läuft hier definitiv etwas falsch!

    Geschätzter Klaus ( Byronic (KS1) )

    Ich brauche hier keine Grundsatzdiskussion, aber ein brauchbarer Lösungsansatz oder die Aussicht dazu schon:

    Es würde mir nämlich schon reichen zu wissen, dass von offizieller Seite aktiv daran gearbeitet wird, denn in dieser Form ist EEP für mich nur frustrierend und für meine Zwecke nicht verwendbar!

    ...und wie Du sagst Lothar ( nohabs :(

    Es ist schon eine (sehr lange) Weile her, seit dieses Problem bekannt ist. Entweder ist es in der aktuellen Engine nicht lösbar und sollte auch so kommuniziert werden, aber so... :aw_1:

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1

  • ich habe das Thema soeben in einem internen Bereich zur Sprache gebracht, wo auch die Entwickler mitlesen. Mal sehen, ob und was das wann ggfs. eventuell unter Umständen möglicherweise hoffentlich irgendwann vielleicht mal bringt.

  • Das ist wirklich lieb von Dir Klaus und im Interesse aller, zu dem Thema Bescheid zu wissen!

    Dann hoffen wir auf offene Gehörgänge... :bc_1:

    Ich wünsche Dir noch einen gemütlichen und schönen Abend

    Freundliche Grüsse

    Alexander

    Signatur

    Brentford Flusi-PC,

    i7-7700k 4.2 GHz,

    NVIDIA GeForce GTX 1080,

    RAM 32 GB,

    Win10 Professional

    EEP5 bis EEP17.2, inkl. Plugin 1