Fehlfunktion des Fahrzeugkontaktpunktes bei Auswahl einer bestimmten Achse über das DropDown-Menü

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Hallo Sven Bauer.

    Ich habe mir dieses schöne Fahrzeug geleistet. Leider habe ich mit der Funktion des Stromabnehmers ein Problem.

    Beim hochfahren oder absenken betätigt er auch den Stromabnehmer der Zuglok, obschon diese unterschiedliche Kennungen haben.

    ( V10NMM20014 BR 101 ) Dort heiß der Stromabnehmer 1 oder 2, beim Bistrowagen ohne Nummer. Desweiteren habe ich bei der Auswahl unterschiedliche Kennungen

    verwendet. Haben Sie eine Idee oder ist ein Ubdate erforderlich?

    Gerne höre ich von Ihnen.

    LG Hans-Peter PÜtz

  • Hallo Hans-Peter,


    vielen Dank für diese Nachricht und die Beobachtung!

    Natürlich ist es sehr schade, wenn solche Fehlfunktionen mit einem Modell in Verbindung gebracht werden und dies vermeintlich schlecht da steht...


    Ich habe es eben ausprobiert und vermute, dass deine Beobachtungen einen gravierenden Fehler in EEP aufdecken könnten, der weder mit dem Modell meines Speisewagens, noch mit der BR 101 vom MM2 zusammenhängt.


    Leider besitzt du keine Signatur und so fehlen uns die Angaben zu deiner EEP-Version, aber meinen kurzen Versuch habe ich eben in EEP11 durchgeführt, und sofern du eine höhere Version benutzt, können wir fast davon ausgehen, dass der Fehler seit Jahren mitgeschleift wird.


    Bei der Steuerung über Kontaktpunkte gibt es ja die Möglichkeit, eine Achse direkt auszuwählen, oder einen Filter nach "Wort" zu setzen.

    Bisher hatte ich es so verstanden, wenn ich bei dem Filter "Stromabnehmer" eintrage, heben sich alle Achsen, also "Stromabnehmer", "Stromabnehmer1" und "Stromabnehmer2".

    Wähle ich hingegen bei den Achsen "Stromabnehmer1" aus, dann hebt und senkt sich auch nur der "Stromabnehmer1" der Lok... und jetzt kommt mit dem Steuerwagen zum ersten Mal ein Modell ins Spiel, dass nur einen Stromabnehmer hat und dieser eben daher auch nur "Stromabnehmer" heißt.


    Und da stellen wir plötzlich fest, dass auch die Auswahl "Achse" nach dem selben Prinzip arbeitet, wie der "Filter"... wenn ich nämlich, so wie du es gemacht hast, "Stromabnehmer" als Achse auswähle, werden tatsächlich alle 3 Achsen, nämlich "Stromabnehmer", "Stromabnehmer1" und "Stromabnehmer2" angesprochen.


    Das ist m.E.n. ein gravierender Fehler, der eben mangels Rollmaterial mit einem Stromabnehmer bisher nie so aufgefallen ist, aber dringend abgeschafft werden muss.


    Die Möglichkeit das Problem kurzfristig zu umgehen, wäre in der INI-Datei des Speisewagens die Achse "Stromabnehmer" anders zu benennen, z.B. "Stromabnehmer-WRmz" oder "Stromabnehmer-BordRestaurant", etc.


    Es tut mir leid, dass ich da als Konstrukteur erstmal nicht in wilde Update-Orgien starten möchte, bevor nicht diese Fehlfunktion näher eingegrenzt ist und ggf. der Handlungsbedarf bei TREND deutlich geworden ist.


    Viele Grüße

    Sven

    Desktop: Windows 10 64-bit auf Asus P7P55D, Intel Core i7 860 2.80GHz, 8GB DDR3-RAM, PCS Radeon R9 380 2048MB

    Notebook: Windows 10 64-bit auf Asus X751, Intel Core i7 4500U, 4GB DDR3-RAM , NVIDIA GeForce 820M

  • Hallo Sven, danke für die schnelle Nachricht. Kannst Du den Stromabnehmer nicht einfach in Stromabnehmer3 oder das Wort KLEIN schreiben?

    Sonst keine Panik bitte, das Modell steht gar nicht schlecht da und ist TOP.

    LG

    Hans-Peter

  • Hallo,


    ich habe das auch mal eben ausprobiert und das gleiche wie Sven festgestellt.

    EIne Lösung von Softwareseite wäre, die Achsenauswahl auch für bestimmte Fahrzeuge festlegen zu können.


    Gruß

    Andreas

    EEP6 / EEP 13.2 / EEP 14 - Modellkonverter - TM14.3.2.1.4 - MK 2.03.006
    win 8.1 64-bit * Intel Core i7-4710HQ CPU 2.50GHz - 8GB RAM - NVIDIA GTX 860M

  • Hallo Andreas,


    bestimmtes Fahrzeug ansprechen geht ja über LUA.


    @all

    Trägt jemand diesen Fehler bitte im Bugtracker ein, damit er auch auf jeden Fall von den Entwicklern zur Kenntnis genommen wird?


    Gruß Michael

    163-katalog-banner-jpg

    Hardwarekonfiguration:
    Laptop: Intel Core i3-3110M 2,4 GHz, 4GB RAM, Win7 64 bit, EEP 6.1/EEP 14.1 Expert Plugin 1

  • Hallo zusammen,


    ich habe das soeben an unsere Programmierer weiter geleitet.

    Viele Grüße
    marler1957


    Intel Core i7-7700 @ 3,60 GHz * Win 10 - 64 bit * 16 GB RAM * NVidia GeForce GTX 1060 - 6GB * 256 GB SSD * 1 TB HDD *

    EEP 13 PlugIn 1 und 2 DEV und User, EEP 14 PlugIn 1 DEV und User

    HomeNos 14 DEV

  • N'Abend,


    naja, "Stromabnehmer3" würden mir die Tester und User sicherlich übel nehmen, bei einem Modelle, dass nur einen Stromabnehmer hat... wir wollen ja immer schön bei der Wahrheit bleiben ;)


    Wie gesagt, die Namensänderung kannst du ja erstmal selbst vornehmen, um das Problem kurzfristig zu lösen.

    Aber korrekter und wichtiger wäre es eben, dass die Funktion in EEP dahingehend geändert wird, dass das Feld "Achse" und dessen Auswahl auch tatsächlich nur die Achse anspricht, deren exakter Wortlaut identisch ist.


    So wie es jetzt ist, ist es ja nur eine zweite Variante des "Filter"-Fensters... nur mit Vorauswahl, statt Freitexteingabe.

    Da muss erst ein Speisewagen mit Stromabnehmer angerollt kommen, bis wir das merken :ao_1:

    Danke für's Weiterleiten an die Verantwortlichen!


    Grüße und schönes Wochenende!

    Sven

    Desktop: Windows 10 64-bit auf Asus P7P55D, Intel Core i7 860 2.80GHz, 8GB DDR3-RAM, PCS Radeon R9 380 2048MB

    Notebook: Windows 10 64-bit auf Asus X751, Intel Core i7 4500U, 4GB DDR3-RAM , NVIDIA GeForce 820M

  • Hallo SB3 Sven, hallo marler1957 ,


    aus Sicht eines Programmierers:

    naja, "Stromabnehmer3" würden mir die Tester und User sicherlich übel nehmen,

    sicher nicht, wenn sie die Hintergründe kennen.


    Für die Achsauswahl eines Zugverbandes "liest" das Programm/EEP m.E. von links nach rechts.

    In obigem Beispiel eben dieses Stromabnehmer und dabei werden auch alle Stromabnehmerxxxangesprochen.

    Das ist sicher so gewollt, weil so variabler einsetztbar.

    Das ist das gleiche Verfahren wie z.B. beim Zugnamen, alle #G_ oder ein spezieller #G_schnell.


    Wie gesagt, die Namensänderung kannst du ja erstmal selbst vornehmen, um das Problem kurzfristig zu lösen.

    "Stromabnehmer-WRmz"

    Das wäre nicht die "kurzfristige" sondern die "richtige" Lösung durch den KON (bitte nicht falsch verstehen :bg_1:)

    Ist jetzt durch deinen Wagen auch für dich neu.

    Und den Achsnamen immer möglichst auf das Fahrzeug bezogen benennen, dann passiert nix falsches.


    Es könnte im Zugverband ja auch ein zweiter Wagen mit Stromabnehmer vorhanden sein.

    Ähnliches Schema wird sicher auch bei den ausfahrbaren Treppentritten angewendet werden.


    Als Beispiel dein Stromabnehmer3:


    Wenn vorne eine Mehrsystemlok zieht, und der KON halt als eingeführtes System die Stromabnehmer mit 1 bis 4 benamst,

    geht das mit deinem Wagen auch in die "Hose".


    Ich hoffe, ich konnte das "Problem" etwas "aufhellen".

    Ich sehe das nicht als Programmfehler, man muss halt auf die richtige Anwendung achten, und ist, s.o., auch für den User leicht korrigierbar.


    :aq_1::bg_1:

    Intel i3-540 3,2GHz 8GB, RAID10, HD 6570 1GB, W7/64 Prof., EEP 6-6.1, 10-14, HN13, MK, TM, "Schiefe Ebene 6 + 8", "Bahn2000"

  • Hallo eep_gogo,


    nein, du konntest das Problem in keiner Weise "aufhellen", sondern verdunkelst und verklärst hier etwas, das wir bereits klar als Problem herausgearbeitet hatten.


    Die Funktionsweise, die du uns beschreibst erfüllt der "Filter" und ermöglicht so das gewünschte Verhalten durch den Begriff "Stromabnehmer" oder "Trittbrett" alle Achsen in Bewegung zu setzen.

    Da ist es gewollt, dass alles was mit "XY" anfängt auch angesprochen wird, egal ob es "XYz" oder "XY3" heißt.


    Wir haben aber eine zweite Funktionsweise im Kontaktpunkt und diese sollte wohl auch aus Sicht eines Programmiers nicht mit der erstgenannten identisch sein, oder?

    Bei der Auswahl einer konkreten Achse aus dem DropDown-Menü sollte ausschließlich diese, dem Wortlaut exakt entsprechende Achse, angesprochen werden, denn sonst ist die ganze Funktion überflüssig!

    Und genau das ist der Programm-Fehler und den wird kein Konstrukteur vermeiden können.


    Solche Beiträge, die ein erkanntes, erklärtes und geprüftes Fehlverhalten von EEP wieder als "richtig" darstellen, sind nicht zielführend!


    Grüße

    Sven

    Desktop: Windows 10 64-bit auf Asus P7P55D, Intel Core i7 860 2.80GHz, 8GB DDR3-RAM, PCS Radeon R9 380 2048MB

    Notebook: Windows 10 64-bit auf Asus X751, Intel Core i7 4500U, 4GB DDR3-RAM , NVIDIA GeForce 820M

  • naja, "Stromabnehmer3" würden mir die Tester und User sicherlich übel nehmen, bei einem Modelle, dass nur einen Stromabnehmer hat... wir wollen ja immer schön bei der Wahrheit bleiben ;)

    Dann benenne ihn doch: "Stromabnehmer0":aq_1:


    Nur ein Vorschlag (bitte nicht erschlagen):az_1:

    An manchen Tagen trete ich nicht ins Fettnäpfchen.

    Ich falle in die Friteuse!:aq_1:

  • Guten Morgen JoSo,


    auch für dich noch einmal zum Mitschreiben:

    Dein Beitrag war in keiner Weise hilfreich und offenbar hast du nichts von dem verstanden, was hier bisher beschrieben wurde!


    ICH KANN DIESES PROBLEM NICHT LÖSEN ! ! !


    Wenn ich die Achse "Stromabnehmer0" nenne, dann finden wir bestimmt einen anderen Konstrukteur, der die Stromabnehmer seiner Lok als "Stromabnehmer01" und "Stromabnehmer02" bezeichnet hat und schon stehen wir wieder vor dem selben Problem.


    Die Funktionsweise des Kontaktpunktes ist in dieser Sache fehlerhaft und muss angepasst werden, da aktuell die beiden Auswahlfelder "Achse" und "Filter" die selbe Funktion erfüllen, anstatt zwei unterschiedle Möglichkeiten zum Ansprechen von Achsen zu bieten.


    Grüße

    Sven

    Desktop: Windows 10 64-bit auf Asus P7P55D, Intel Core i7 860 2.80GHz, 8GB DDR3-RAM, PCS Radeon R9 380 2048MB

    Notebook: Windows 10 64-bit auf Asus X751, Intel Core i7 4500U, 4GB DDR3-RAM , NVIDIA GeForce 820M

  • Hallo Sven,


    auch wenn dort ein Fehler ist, was die Eingabe betrifft und wie es ausgewertet und weiterverarbeitet wird, der Fehler ist dabei nicht aus der Welt geschafft. Im Kontaktauswahlmenü fehlt die Ansteuerung der Achse vom Rollmaterial im Zugverband. Hat der Zugverband zweimal die Achsenbezeichnung "Stromabnehmer" wird es weiterhin so bleiben, wie bisher. Hier hilft nur, wenn man das Rollmaterial direkt anspricht, denn über Lua funktioniert das ja. Und das sollte auch über den Kontaktpunkt-Auswahlmenü funktionieren, ohne Lua.

  • Also, lieber Sven , ich sage es gerne nochmal: Das Modell ist TOP und durch die Fehlfuktion wird es nicht weniger schön. Und die Frage für Doofe: Nicht jeder , der EEP benutz ist auch Kompi-Spezialist. Wie komme ich in die von Dir genannte Datei rein und was muss ich da machen.? DAnke vorab.

    LG Hans-Peter

  • Wie komme ich in die von Dir genannte Datei rein

    Hallo Hans-Peter :)


    ich bin mir jetzt nicht ganz sicher, nehme aber an, es geht um das Set V11NSB30136. Ich besitze das Set (noch) nicht. Aber laut Shopbeschreibung

    Die Modelle befinden sich unter

    Resourcen\Rollmaterial\Schiene\Personenwaggons

    DB WRmz137 or 04 EpIV +

    DB WRmz137 or 05 EpIV +

    DBAG WRmz137.0 or 01 EpV

    Warnung: bitte vor jeder Aktion unbedingt ein Backup erstellen, mindestens der zu ändernden Dateien, am besten der gesamten Ressourcen.


    Unter jedem dieser drei Namen findest Du im angegebenen Ordner Deiner EEP-Installation u.a. eine *.ini Datei. Doppelklick darauf öffnet sie im Windows-Editor. Dort findest Du u.a. eine Zeile wie

    Code
    1. MovAxis7_GER = "Stromabnehmer"

    Den Text am Zeilenende könntest Du wie von SB3 vorgeschlagen ändern. Wenn Du magst, kannst Du auch einen beliebigen anderen Namen vergeben.


    Gruß Ingo

    Win 7x64 Professional SP1, Intel Core i5-3570, 16GB RAM, nVIDIA GeForce GT630, 2GB, 1920x1200 auf 26" TFT

    Windows Firewall und Defender (MSE)

    EEP6 Patch 1; EEP8.3 Expert; EEP9 Expert Patch 1; EEP10.2 Expert Patch 3 Plugin 1; EEP11.3 Patch 1; EEP12.1 Expert Patch 1; EEP13.2 Patch 2 Plugins 1,2; EEP14.1 Expert Patch 2 Plugin 1