Building 4 Lane Road Cloverleaf

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • I’m trying to create a 4 lane road cloverleaf (2 lanes in the same direction) like we see on our Interstate roads in the U.S A. The Road Crossing X junction found in the street objects only provides 1 lane in a direction.

    I’ve utilized 8 one-way road pavements. The situation I’m having trouble with concerns only 2 one-way roads, both going in the same direction. An identical situation occurs 3 more times. Unfortunately, I could not find any available traffic lights that controls traffic in the same direction. The traffic lights I’m using are the “Traffic signal light-Germany-3” on one of the lanes and a “x_Invisible_Signal” on the other lane. The Lua code I’ve written controls both of these very nicely.

    HOWEVER, PLACING A VEHICLE ON EACH LANE (2 vehicles total) , the vehicle on the lane with the “Germany-3” signal responds properly.

    The VEHICLE ON THE LANE WITH “x_Invisible_Signal” DOES NOT RESPOND EVEN THOUGH THE SIGNAL IS SET TO STOP, IT JUST CONTINUES ON AS IF THERE WERE NO SIGNAL. I’VE TRIED USING DIFFERENT SIGNALS WITHOUT ANY SOLUTION. I’M AT A LOSS ON HOW TO CORRECT THE PROBLEM.

    ANY HELP OR SUGGESTION WILL BE GREATLY APPRECIATED.

  • chucksim2


    I think your best option would to be to use V13NDH10053 by DH1 for traffic lights. I find it very useful when using one way road systems.


    a picture of what you have made thus far would be very helpful, and some might be able to offer more ideas.


    Craig in sunny Scotland .. ( well it is toady) :an_1:


    in fact I would love to see pictures and I do enjoy building USA style layouts

    :ak_1:Win10 home 64bit , HP Omen , 16 GB ram, Nvidia GTX 1060 3GB, intel i5-7400 @3GHz
    EEP3, EE5 (2008 version). RailroadX (Steam) Plugins 1 & 2 EEP 12

    & EEP 13 .2 (Steam) Expert version Plugin 1 & 2

    EEP 14 Expert (EN trend version) HomeNos 14.0

    EEP 15 Expert HomeNos 15.0


    The more I learn, the more I realise I don't know.

    I use "DeepL Translator" for reading and posting in German

    Ich benutze "DeepL Translator" zum Lesen und Posten auf Deutsch.

  • The type of signal shouldn't play a role whether a car stops or not.


    Are you sure that the invisible signal is placed on the correct road piece (not on a separate sidewalk or similar)?

    Is the car in automatic mode? Vehicles in manual mode don't respond to signals at all.

    Where is the pre-signal placed? In EEP, vehicles start breaking when they pass the pre-signal. If the car already passed the pre-signal before, it will also pass the main signal.


    Kind regards,

    Benny

  • What Benny writes is VERY important.

    When you place a signal, visually it looks like the main point is the Signal, and the secondary point is the Pre-Signal. But the game is programmed so that the Pre-signal position is actually the main x,y,z-position and the main signal is an attached information to the pre-signals x,y,z-position.

    Hence that it is extremely important that you focus on the Presignal is something doesn't work, and secondary on the main signal.

    Like Craig I am very interested in US rail-fanning, and I think you might get a little further with your support quest in here, if you attach some explanatory pictures and screenshots.

    All the best - and please stay active in here (we neeeeeeed Americans)

    All the best
    Dennis (Denmark)

    Win 10 Home 64bit - i5 6600K CPU 3,5GHz - 32Gb Ram - NVIDIA GeForce 1060 6Gb

    EEP 13 Expert (ENG Steam edition) Update2 - EEP 14 Expert (DE Trend edition)

    EEP Bodentextur-Tool, EEP TSPCalc, EEP Texture Multiplier, EEP Model Multiplier,

    EEP Model Files Converter, EEP HomeNOS13, Blender v2.78b, Adobe Photoshop

  • I finally remembered that I had a similar problem a few years ago that Goetz solved for me. I had somehow placed a copied lane over the problem lane. Once I deleted the copied lane, everything worked fine.

    I thank all of you for your help and suggestions.

    The suggestion to include screenshots, etc will be followed in the future. Thanks.


    While on the subject of signals, signal x_Invisible_Signal (logic). The signal aspect has numbers from 1 thru 99. How and where are these utilized?