Eigenart inEEP Der Zug (ein Rollmaterial) hat die falsche Richtung nach dem Kuppeln!

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Guten Abend.


    Das Rollmaterial hat die falsche Richtung nach dem Kuppeln!


    Das kann jeder User selbst testen.

    Vorgehensweise:


    - Leere Anlage laden.

    - In der Anlageninformation „Sanftes Ankuppeln“ aktivieren.

    - 3 Gleise legen (können auch mehr oder weniger sein).

    - 2 Rollmaterialien mit Antrieb wählen. Am Besten solche, wo man gleich sieht, wo Vorn und Hinten ist.

    - Die Loks so setzen, dass die „Schnauzen“ entgegengesetzt sind.

    - Jetzt mit einer Lok losfahren und sanft ankuppeln.

    - Wenn der Kupplungsvorgang abgeschlossen ist, dann die Lok nehmen, welche nicht fuhr und abkoppeln.

    - Jetzt die Lok nehmen, welche fuhr und wieder zurückfahren.

    - Jetzt mal im Steuerdialog für die stehende Lok eine Geschwindigkeit eingeben.

    - Die Richtung stimmt nicht mehr!


    Diese Eigenart hatte ich auch schon in EEP13, konnte den mir aber damals nicht erklären, wann die Richtung nicht mehr stimmte. Ich dachte immer, es liegt daran, wenn ich am Prellbock dran fuhr.

    MfG. Jörg
    Notebook: i7-6700K, 4[8]x4.0 GHz, 32GB RAM DDR4, NVIDIA GTX 980M 8GB, Windows 10, 64-Bit
    installiert: EEP6.1; EEP14.1 expert Patch2 mit Plugin 1; EEP15.1 Patch2 mit Plugin 1

    Zusatzprogramme: EEP Zug-Explorer, EEP Modell-Explorer, JWGleisEditor, ResourcenSwitcher2

    The post was edited 1 time, last by Tufftuff ().

  • Hi Tufftuff ,

    wenn Fahrzeuge mit Antrieb gekoppelt sind, müssen sie doch die gleiche Fahrtrichtung haben. EEP wird wohl die Fahrtrichtung des angekoppelten Fahrzeug anpassen.:aa_1:


    MfG :co_k:

    EEP 15
    MS Windows 10 Pro 64bit
    Prozessor: AMD FX-8370 Eight-Core Processor 4,0GHz // RAM: 32GB // SSD 128GB // Grafikkarte: GeForce GTX 950

  • Hallo kaffeschluerfer ,


    wo steht, dass sie noch gekoppelt sind?

    Ich fahre nur mit der Lok an die andere Lok ran und kupple, danach wird wieder abgekoppelt. Danach fährt die "fahrende" Lok wieder zurück. Die Lok, welche eh die ganze Zeit stand, hat jetzt eine falsche Richtung, wenn man ihr eine Geschwindigkeit gibt.

    MfG. Jörg
    Notebook: i7-6700K, 4[8]x4.0 GHz, 32GB RAM DDR4, NVIDIA GTX 980M 8GB, Windows 10, 64-Bit
    installiert: EEP6.1; EEP14.1 expert Patch2 mit Plugin 1; EEP15.1 Patch2 mit Plugin 1

    Zusatzprogramme: EEP Zug-Explorer, EEP Modell-Explorer, JWGleisEditor, ResourcenSwitcher2

  • Hallo Tufftuff  

    Das Rollmaterial hat die falsche Richtung nach dem Kuppeln!

    Da muss ich Dir widersprechen: Dem Rollmaterial geht es gut, und es weiß auch noch, wo vorne und hinten ist. :av_1:

    Das kannst ganz einfach in der manuellen Steuerung überprüfen, indem Du einen Vorwärtsgang wählst, die Bremse löst und Gas gibst.


    Der Zug (auch wenn er nur aus einem Rollmaterial besteht) hat nach solch einem Vorgang allerdings die umgekehrte Richtung. Das liegt daran, dass beim Kuppeln der schnellere Zug seine Einstellungen an den entstehenden neuen Zug übergibt. Ob sanft gekuppelt wird oder nicht, spielt übrigens keine Rolle. Insbesondere wird die Richtung des kuppelnden Zuges an den neuen Zug übergeben, also die Festlegung, wo vorne und hinten sind. Beim Trennen des Zugs erhalten beide Zugteile die Einstellungen des ursprünglichen Zugs. Und damit sind jetzt Vorne und Hinten der beiden Teilzüge nicht mehr unbedingt intuitiv.


    Ich spreche nicht darüber, ob das ein Fehler ist; ich wollte nur erläutern, wie die Dinge zusammenhängen.


    Gruß

    Christopher

    PC: Intel i7-7700K; 64bit; 4,2 GHz; 16GB RAM; GeForce GTX 1080 (8 GB); Win 10; EEP 6, 13.2 Plugins 1+2, 14.1 (Dev), 15 (Dev); HomeNOS 14 (Dev)
    Laptop: Intel i5 3230M; 64bit; 2,6 GHz; 8GB RAM; GeForce GT740M (1 GB); Win 8.1; EEP 6, 13.2 Plugins 1+2; HomeNOS 13 (User)

  • Ja der Fehler ist mir auch schon aufgefallen, ist voll nervig.

    Vor allem wenn man Vorspann gefahren ist und nachdem die Vorspannlok wieder weg ist fährt der eigentliche Zug danach bei positiver (Vorwärts) eingegebener Geschwindigkeit plötzlich rückwärts und halt umgekehrt.

    Denn bei E- und V- Loks sind nicht immer beide Loks mit der Schnauze nach vorne.

  • Hallo Christopher,

    vielen Dank für die Erklärung.

    Ich habe den Titel angepasst.

    Könnte jemand bitte so nett sein, das Thema nach Rollmaterial bzw. Steuerung, Danke.

    Werde am Abend noch was dazu schreiben.

    MfG. Jörg
    Notebook: i7-6700K, 4[8]x4.0 GHz, 32GB RAM DDR4, NVIDIA GTX 980M 8GB, Windows 10, 64-Bit
    installiert: EEP6.1; EEP14.1 expert Patch2 mit Plugin 1; EEP15.1 Patch2 mit Plugin 1

    Zusatzprogramme: EEP Zug-Explorer, EEP Modell-Explorer, JWGleisEditor, ResourcenSwitcher2

  • Guten Abend :bg_1:,


    zurück zum Thema, warum schreiben dann Kon's an den Türen ne 1 und ne 2 dran, wenn man sich danach sich nicht richten kann und über Lua dementsprechend die Lok nicht mehr richtig steuern kann?

    Hier kann ich nicht das Rollmaterial (RM) steuern, sondern nur den Zug (oder auch Zugverband (ZV).

    Dem Rollmaterial geht es gut, und es weiß auch noch, wo vorne und hinten ist.

    Das weiß ich auch :bn_1:, aber ich kann über Lua nur den Zug (ZV) ansprechen, genauso im Steuerdialog im Automatikmodus (Dort wo man positive oder negative Zahlen eingibt, oder über den Schieberegler.).

    Hier liegt insgesamt eine "Eigenart von EEP" vor, das betrifft auch die ID-Vergabe der RM und ZV, ist aber ein anderes Thema.

    Wenn eine Lok alleine steht oder fährt, dann sollte immer Vorn Vorwärts sein und Hinten Rückwärts.

    Solange man nur mit Kontaktpunkten arbeitet, fällt so was nicht auf. Nur mit Lua sieht es anders aus.

    Hans-Christian ( Hans-Christian (HS1)   ) kann mit der jetzigen Situation vielleicht auch nicht ganz glücklich sein, denn seine Skripte sind ähnlich aufgebaut. Denn im Endeffekt fährt das Rollmaterial dann auch in die falsche Richtung, über den Trafo gesteuert.

    OK, wenn das nur eine Eigenart von EEP ist, dann habe ich mich über mehrere "Tage" sinnlos beschäftigt. Dann nehme ich alle meine Skripte raus, denn ich möchte nicht User bewusst "fehlerhafte" Skripte liefern, nur weil EEP eine "Eigenart" hat. :au_1:

    Ich spreche nicht darüber, ob das ein Fehler ist; ich wollte nur erläutern, wie die Dinge zusammenhängen.

    Und Du hast dir nicht selber die Frage gestellt, ist das Richtig? :as_1:


    Vielen Dank an den Admin oder Moderator, der die Beiträge verschoben hatte.:aq_1:


    MfG. Jörg
    Notebook: i7-6700K, 4[8]x4.0 GHz, 32GB RAM DDR4, NVIDIA GTX 980M 8GB, Windows 10, 64-Bit
    installiert: EEP6.1; EEP14.1 expert Patch2 mit Plugin 1; EEP15.1 Patch2 mit Plugin 1

    Zusatzprogramme: EEP Zug-Explorer, EEP Modell-Explorer, JWGleisEditor, ResourcenSwitcher2

  • Tufftuff : Aber mit Lua kannst Du durch die Callback-Funktionen auf jedes An- und Abkuppeln reagieren und Dir so merken, ob Vorne und Hinten vertauscht sind oder nicht...


    Gruß

    Christopher

    PC: Intel i7-7700K; 64bit; 4,2 GHz; 16GB RAM; GeForce GTX 1080 (8 GB); Win 10; EEP 6, 13.2 Plugins 1+2, 14.1 (Dev), 15 (Dev); HomeNOS 14 (Dev)
    Laptop: Intel i5 3230M; 64bit; 2,6 GHz; 8GB RAM; GeForce GT740M (1 GB); Win 8.1; EEP 6, 13.2 Plugins 1+2; HomeNOS 13 (User)

  • ich kann über Lua nur den Zug (ZV) ansprechen

    Mit dem kommenden Plug-In bekommst du die Funktion EEPRollingstockGetOrientation()

    Die liefert dir die Ausrichtung des Fahrzeugs relativ zum Fahrzeugverband.

    Oder anders gesagt: Sie zeigt dir, ob die Fahrtrichtung des Zuges mit der des Rollmaterials übereinstimmt oder gedreht wurde.


    Du musst bitte verstehen, dass ein Zug aus mehreren Fahrzeugen bestehen kann, die uneinheitliche Richtungen haben. Deshalb stimmt die Zugrichtung nicht unbedingt mit der Ausrichtung eines Fahrzeugs im Zugverband überein. Ein Zug, der aus nur einem Fahrzeug besteht, ist im Grunde nur ein Sonderfall. Und der bekommt in EEP keine Sonderbehandlung. Deshalb kann nach einem Kupplungsmanöver die Zugrichtung anders sein als die Fahrzeugrichtung.


    Ich verstehe, warum das für dich ein Ärgernis ist. Ich will dir nur verdeutlichen, dass dahinter keine Willkür steckt und auch kein Unwillen. Sondern ein vernünftiges System, das in einem Spezialfall ein anderes Ergebnis liefert als das von dir ersehnte.


    Ein Lua Befehl, der die Zugrichtung umkehrt, wäre sicher eine gute Idee für die Wunschliste.

  • reagieren und Dir so merken, ob Vorne und Hinten vertauscht sind oder nicht...

    Dann müsste ich ja bis zu 98 RM pro Trafo überwachen. Mache ich bestimmt nicht, bei der Schiebebühne sieht es nicht besser aus. Das mache ich bestimmt nicht, da müsste ich ja jeden Kupplungsvorgang auswerten.


    Mit dem kommenden Plug-In bekommst du die Funktion EEPRollingstockGetOrientation()

    Die liefert dir die Ausrichtung des Fahrzeugs relativ zum Fahrzeugverband.

    Oder anders gesagt: Sie zeigt dir, ob die Fahrtrichtung des Zuges mit der des Rollmaterials übereinstimmt oder gedreht wurde.

    Ok, damit könnte ich leben, da ich die Funktion eh gewünscht hatte. Aber für die User, welche mit den Tasten "A", "S" und "D" den Zug (Lok) steuern möchten, bleiben bei der vertauschten Richtung.

    Und der bekommt in EEP keine Sonderbehandlung. Deshalb kann nach einem Kupplungsmanöver die Zugrichtung anders sein als die Fahrzeugrichtung.

    Das sehe ich aber ganz anders. Denn erst beim Kelkheimer Treffen, haben wir gesehen, dass Loks nicht immer die gleiche Richtung haben im Zugverband. Vorne eine MAK in Fahrtrichtung, danach kamen die Personenwagen und zum Schluss kam eine 01er in entgegengesetzter Fahrtrichtung .

    Die MAK ist vorwärts runter gefahren, die 01er vorwärts den Berg rauf. Jetzt wurden aber an der MAK die Räder zu heiß, deshalb musste die MAK abkuppeln und an ein Stumpfgleis gebracht werden. Die 01er wurde umgesetzt. Das geht nicht, da die 01er die Richtung von der MAK hat, aber nur in EEP. Ich weiß, ist nur ein Sonderfall...........


    Sondern ein vernünftiges System, das in einem Spezialfall ein anderes Ergebnis liefert als das von dir ersehnte.

    Das ist deine Meinung, ich habe dazu eine andere Meinung. Ein vernünftiges System, welches verbesserungswürdig wäre. Aber lassen wir das. Mit dem Plugin geht es zumindest für die Trafo- und Schiebebühnen-Steuerung.

    MfG. Jörg
    Notebook: i7-6700K, 4[8]x4.0 GHz, 32GB RAM DDR4, NVIDIA GTX 980M 8GB, Windows 10, 64-Bit
    installiert: EEP6.1; EEP14.1 expert Patch2 mit Plugin 1; EEP15.1 Patch2 mit Plugin 1

    Zusatzprogramme: EEP Zug-Explorer, EEP Modell-Explorer, JWGleisEditor, ResourcenSwitcher2