DKW schalten falsch (GK3)

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Hallo EEP-Freunde,


    mir ist am Beispiel der beiden Demoanlagen von GK3 ("DKW" und "vier GK3 DKWs") aufgefallen, dass die DKW aus der gleichnamigen Anlage nicht mehr richtig schaltet. So laufen z.B. die Weichenzungen gegenläufig und die Anzeige des Signals DKW stimmt nicht immer mit den Weichenstellungen überein. Bei der anderen Anlage treten diese Fehler nicht auf. Ein kurzer Test mit anderen DKWs (GK3) auf einer neuen leeren Anlagen bestätigte diesen Fehler, der nur auftritt wenn das eigentliche Weichenstück eine Gleislänge von 1m aufweist. Könntet ihr dies mal bitte überprüfen?


    Danke und Gruß

    SachsenFahrer

    PC: IntelCore i5 4460 auf ASUS H97-Pro Gamer; 20 GB Ram; GeForce GTX 750 Ti (2 GB), Win10 64bit
    installierte EEP-Versionen: 6, 9, 15 - aktive EEp-Version: 16 (jeweils mit allen Updates)

  • Hallo Sachsenfahrer,


    ich kann das bestätigen. Bei meiner "Kreiensen"- Anlage habe ich die DKWn mit einem Skript von Götz mit ihren Laternen verschaltet.


    Das Skript wird hier vorgestellt: Brauche Hilfe bei GK3-DKW und Schatten-DKW für GBS


    In EEP15 funktioniert alles reibungslos, in EEP16 leider nicht mehr. Es kommt Fehlstellungen, wie auf dem Bild, obwohl die eingetragenen ID´s noch stimmen:


    eepforum.de/attachment/28691/

    Gruß, Andi


    The sun always shines in EEP :ae_1:


    Intel i5-8600K, Geforce GTX 1060 6GB, Asrock Z370 Pro4, 32 GB Ram, Samsung SSD, Win 10 64bit (Build 18362.145)


    In Betrieb EEP16.1, Patch2, Plugin 1

  • Falls ihr die DKWs neu eingesetzt habt prüft bitte mal, ob die intern noch "wenn ... dann" verkoppelte Weichen enthalten. Das harmoniert nämlich nicht mit meinem Skript.

    "Importance always means one thing in relation to another. There is no such thing as importance alone."

    - morn1415 -

  • Hallo Götz,


    ich habe einfach nur die mit EEP15 gebaute Anlage, unverändert, in EEP16 geladen.


    Trotzdem habe ich die DKWn mal auf "wenn...dann" verknüpfungen überprüft. Ergebnis: es sind keine vorhanden.

    Gruß, Andi


    The sun always shines in EEP :ae_1:


    Intel i5-8600K, Geforce GTX 1060 6GB, Asrock Z370 Pro4, 32 GB Ram, Samsung SSD, Win 10 64bit (Build 18362.145)


    In Betrieb EEP16.1, Patch2, Plugin 1

  • Hallo,


    ich mußte bei einer Anlage mit einem 16 gleisigen Kopfbahnhof ca. 90% der GK3-DKW löschen und neu einsetzen, da sie nach Wechsel auf EEP16 nicht mehr korrekt arbeiteten.

    (Gegenläufige Weichenzungen).

    Danach schalteten sie wieder korrekt:bq_1::bk_1:


    Viele Grüße Reiner

    Windows 10 Home 64 bit, Intel® Core™ i7-6700k Processor 4 x 4000 MHz,(4633 Mhz mit Wasserkühlung)

    Palit Geforce GTX 1060 /6 GB , DDR4-2133 16 GB) --->> und kein Zug ruckelt mehr<<---:ap_1:


    Fast alles ab EEP4

  • Hallo Goetz,


    ich verwende ebenfalls Dein Skript für GK3-DKW.

    Wenn man das parallel liegende Weichenpaar nicht mit wenn-dann verknüpft, dann schaltet nur eine Weichenzunge und das ist nicht realistisch.

    Also verknüpfe ich mit "wenn Fahrt,dann Abzweig".

    Es funktionierte wunderbar, bis zu EEP16. Danach musste ich verschiedene DKW neu einsetzten.

    An der Verschaltung hatte sich nichts verändert, die Weichenzungen liefen nur gegenläufig.

    Allerdings nicht "alle".


    Reiner

    Windows 10 Home 64 bit, Intel® Core™ i7-6700k Processor 4 x 4000 MHz,(4633 Mhz mit Wasserkühlung)

    Palit Geforce GTX 1060 /6 GB , DDR4-2133 16 GB) --->> und kein Zug ruckelt mehr<<---:ap_1:


    Fast alles ab EEP4

  • Ich glaube fast, dass hier auch die Problematik der kurzen Gleisstücke hineinspielt.

    Freundliche EEP-Grüsse,

    Volker. :aq_1:

    Win10Pro (64) - 1909 (19H2)_Build 18363.657 - 16GB AS - i7-4720HQ Turbo: 3,5 Ghz / 3 GB NVIDIA 970M
    EEP : alle ab 4.0 - Installiert: ( 15.1 - Patch 2 - Plugin 1 ) - EEP 16.1 - Patch 4 & PlugIn 1 / Hugo, Modellkatalog

  • Wenn man das parallel liegende Weichenpaar nicht mit wenn-dann verknüpft, dann schaltet nur eine Weichenzunge

    Nein, mit meinem Skript schalten ohne Verkopplung beide Zungen. So, wie es richtig ist (da sie gemeinsam mit einer Stange bewegt werden.)

    Mit Verkopplung ruft die mitgeführte Zunge im Skript das falsche Ereignis auf und die Seite am anderen Ende schaltet dann in der Folge falsch.

    "Importance always means one thing in relation to another. There is no such thing as importance alone."

    - morn1415 -

  • Vielleicht hat EEP16 ja einfach nur die ID im Vergleich zu EEP15 vertauscht ? Siehe Thema Signale ;)


    Das wäre zwar naheliegend, Tovak, aber es ist nicht der Fall. Habe das überprüft.

    Gruß, Andi


    The sun always shines in EEP :ae_1:


    Intel i5-8600K, Geforce GTX 1060 6GB, Asrock Z370 Pro4, 32 GB Ram, Samsung SSD, Win 10 64bit (Build 18362.145)


    In Betrieb EEP16.1, Patch2, Plugin 1

  • Es könnten auch Fahrt/Abzweig der Weichenantriebe vertauscht sein? (das Thema interessiert mich natürlich auch).

    EEP 15 Patch 2 Plugin 1 - Intel i5 CPU 3.2 GHz, 12 GB RAM - GeForce GTX 760 - Windows 10 Home.

    Epoche III und IV - Diesel und Dampf im und am Westharz - pedantic bis fantasy. Aktuelles Lernfeld: Oberleitungsbau.

    Altenau/Harz | Börssum - mit Tobi | Klein Mahner

    The post was edited 1 time, last by gonz ().

  • Hallo EEP-Freunde,


    habe gerade nochmal die DKW-Weichen (GK3) getestet und diesmal mit dem Script von Götz betrieben. Es sind nicht alle DKW betroffen, sondern offentsichtlich nur die Holzreihe (z.B.: DKW54_300_1-9_H-ARLE_GK3 - siehe Bild). Die Weichen sind nicht verknüpft und bis auf die DKW ist die Anlage jungfräulich. Beim Einsetzen fehlt auch die Fehlermeldung aus Bild 2. Das Weichenstück (Gleis) dieser DKW ist 1,001 m lang mit einem Winkel von 0,615.


    Gruß

    SachsenFahrer

  • Habe gerade mal in eine mit Holz-DKWs von GK3 bestückte Anlage mit EEP16 reingeschaut.

    Die schalten ja alle falsch. Was in V14 einwandfrei ging stimmt in V16 absolut nicht mehr.

    Sicher könnte man im Lua- Script die Zuordnung der Weichen zum Laternensignal passend machen aber das kann ja nicht die Lösung sein.

    Ich hoffe sehr das diese und die Problematik der kreativen Signale bald gelöst wird.

    Grüße, Jörg

    Win7 64 Bit Intel i5-4210H 2,9Ghz 16GB GForce GTX 850M EEP6.1, 14 und 16

    Eigenbau: Muldentalbahn, Leipzig- Wahren, Beucha- Trebsen, Eilenburg 1970

    Aktuell: Die Delitzscher Kleinbahn

    Bahnstrom macht klein, schwarz und häßlich und

    musst Du Gleise überschreiten sieh zuvor nach beiden Seiten!


    Ganz wichtig:

    Die Ausrede muss glaubhaft wirken und einer ersten Überprüfung standhalten können!

  • Die schalten ja alle falsch.

    Die schalten optisch falsch, werden aber korrekt befahren. Im abgebildeten Beispiel steht die DKW im GBS auf "Kreuzen", wird auch so befahren, aber, wenn ich das richtig sehe, stehen die Zungen auf "Abzweig". War mir so bisher noch nicht aufgefallen. Ich bin entsetzt!




    P.S.: Grade nochmal in EEP 15 geprüft, da schaltet die DKW korrekt, und am Skript habe ich nichts geändert.

    Betriebssystem: Windows 10 Home 64bit

    Prozessor: Intel Core i9-9980 HK @ 2,4 GHz (16CPUs)
    32GB RAM
    Grafik: NVIDIA GeForce RTX2070 8GB

    EEP 15, Patch 2

    EEP 16.1 Patch 4 , Plugin 1

    The post was edited 1 time, last by Onkelwoody ().

  • War mir so bisher noch nicht aufgefallen. Ich bin entsetzt!

    Sage ich doch, Woody. Ob die Weichen innerhalb der Fahrstraßen in die benötigte Lage gelegt werden habe ich nicht überprüft. Beide Zungen einer Seite sollten gemeinsam in eine Richtung gelegt werden (bei richtiger Wenn-dann- Beziehung), eine Seite der Weichen tut das auch. Die andere Seite legt die Zungen gegenläufig. Obwohl die Beziehungen richtig eingetragen sind.

    Da stellen sich mir zwei Fragen: beabsichtigen die Herrschaften in Buggingen diesem Bug abzuhelfen? Da wäre mal eine Ansage von Leuten welche die nötigen Kontakte haben hilfreich.

    Die andere wäre: was passiert einem wenn er jetzt in V16 DKWs verbaut und der Bug dann gefixt wird?

    Grüße, Jörg

    Win7 64 Bit Intel i5-4210H 2,9Ghz 16GB GForce GTX 850M EEP6.1, 14 und 16

    Eigenbau: Muldentalbahn, Leipzig- Wahren, Beucha- Trebsen, Eilenburg 1970

    Aktuell: Die Delitzscher Kleinbahn

    Bahnstrom macht klein, schwarz und häßlich und

    musst Du Gleise überschreiten sieh zuvor nach beiden Seiten!


    Ganz wichtig:

    Die Ausrede muss glaubhaft wirken und einer ersten Überprüfung standhalten können!

  • Was bedeuten eigentlich diese kleinen blauen Striche?

    Und kann man so eine DKW irgendwie mit einem Klick gegen eine andere tauschen- so wie mann das mit vorher ausgewählten Immos oder Rollis kann?

    Grüße, Jörg

    Win7 64 Bit Intel i5-4210H 2,9Ghz 16GB GForce GTX 850M EEP6.1, 14 und 16

    Eigenbau: Muldentalbahn, Leipzig- Wahren, Beucha- Trebsen, Eilenburg 1970

    Aktuell: Die Delitzscher Kleinbahn

    Bahnstrom macht klein, schwarz und häßlich und

    musst Du Gleise überschreiten sieh zuvor nach beiden Seiten!


    Ganz wichtig:

    Die Ausrede muss glaubhaft wirken und einer ersten Überprüfung standhalten können!

  • Hallo Wahrener ,


    Die blauen Striche sind virtuelle Verbindungen, die seit EEP16 bei allen GK3 Weichen auftauchen. Sind wahrscheinlich auch dafür verantwortlich, das nicht immer sauber angedockt werden kann.

    Bei mir dockt der gerade Strang immer sauber an. Nur der abbiegende macht hin und wieder Probleme.

    Hoffe das wird korrigiert ...


    Gruß Günter

    Gruß aus Halle

    EEP Fan



    Intell i7-2600 3,4GHz,32GB DDR3-RAM,NVIDA GeForce GTX 1070, 8GB, Windows 10 Pro 64bit
    EEP 5,6,7,8,9,X,11 Plugin 2, 12, 13 Plugin 1 und 2, 14.1 Expert, EEP15 Expert, EEP16 auf SSD


    Modellkonverter, Modell- und Texturemultiplier, PlanEx 3.2, MET, EEPH

  • Danke Günter.

    Zwei Feststellungen:

    eine neu eingesetzte DKW kann man problemlos über das Kontextmenü gegen ein anderes GO tauschen.

    Bei den vorhandenen fehlerhaft schaltenden DKWs geht das nicht, der Menüeintrag fehlt.

    Und: beim Versuch eine 500er DKW zu erstellen bekommt man das hier:


    Grüße, Jörg

    Win7 64 Bit Intel i5-4210H 2,9Ghz 16GB GForce GTX 850M EEP6.1, 14 und 16

    Eigenbau: Muldentalbahn, Leipzig- Wahren, Beucha- Trebsen, Eilenburg 1970

    Aktuell: Die Delitzscher Kleinbahn

    Bahnstrom macht klein, schwarz und häßlich und

    musst Du Gleise überschreiten sieh zuvor nach beiden Seiten!


    Ganz wichtig:

    Die Ausrede muss glaubhaft wirken und einer ersten Überprüfung standhalten können!

  • Hallo Wahrener ,


    Die Fehlermeldung kommt bei mir auch, aber ich kann die 500er Weichen einsetzen und sie funktionieren dann auch.


    Gruß Günter

    Gruß aus Halle

    EEP Fan



    Intell i7-2600 3,4GHz,32GB DDR3-RAM,NVIDA GeForce GTX 1070, 8GB, Windows 10 Pro 64bit
    EEP 5,6,7,8,9,X,11 Plugin 2, 12, 13 Plugin 1 und 2, 14.1 Expert, EEP15 Expert, EEP16 auf SSD


    Modellkonverter, Modell- und Texturemultiplier, PlanEx 3.2, MET, EEPH