Die Einträge "Auf Fahrzeug/Zug anwenden:" sind teilweise nicht mehr vorhanden

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Morgen zusammen.

    Habe ein Problem mit den Kontaktpunkten für Fahrzeuge.

    Die Einträge "Auf Fahrzeug/Zug anwenden:" sind teilweise nicht mehr vorhanden.

    In der 2D Ansicht kann das entsprechende Fahrzeug ausgewählt werden.

    Wechsel zur 3D Ansicht und der Einrag ist weiß. Also ohne jeglichen Eintag.

    Beim Versuch das Fahrzeug in 3D einzutragen ist nicht möglich, da es nicht in der Auswahl aufgeführt ist.

    Einfügen in Gruppenkontakte bringt keine Änderungen.

    Kann aber nicht immer reproduziert werden. Tritt auch manchmal nach mehrmaligen öffnen auf.

    Dies hat zur Folge das die Funktion, in meinem Fall "Einstellungsgruppe" auf alle Fahrzeuge zutrifft.

    Ist dies jemandem sonst noch aufgefallen?

    Gruß Jochen

    ASUS X751LX
    Intel Core i7-5500U CPU @ 2.40GHz
    12,0GB Dual Kanal DDR3 @ 798MHz
    NVIDIA GeForce GTX 950M
    2047 MB
    Windows 10 Home 64-bit

    EEP 16.1 Expert Patch 4

  • Opa Joe

    Die Einträge "Auf Fahrzeug/Zug anwenden:" sind teilweise nicht mehr vorhanden.

    Hallo Jochen,


    ich kann das bestätigen. Dieser Fehler tritt bei mir auch auf.

    Manchmal werden nur wenige Fahrzeuge angezeigt. Bei mehrmaligem Öffnen des Fensters sind einmal nur wenige Fahrzeuge angezeigt, das nächste mal mehrere und dann wieder alle.

    Habe noch keinen Grund gefunden warum das so ist.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.1 Expert (x64),Patch 4, PlugIns: 1; EEP 15.1 Expert(x64), Patch 2, PlugIns: 1; PlanEx 3.1; PlanEx-Easy


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.752

  • Hallo,

    habt Ihr mal versucht, das Feld in dem die Fahrzeuge angezeigt werden doppelt anzuklicken bis es blau hinterlegt ist und dann mit dem Mausrad zu rollen?

    Gruß
    Dieter

    -----------------------------------------------------------------------------------

    Schalten und walten ist mein Hobby, aber nur in EEP ;)
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 16GB RAM, 500GB SSD, 2 TB HDD, GT 850 von Nvidia, Windows 10 Home 64bit

  • icke

    Sind auf der Anlage vielleicht virtuelle Depots vorhanden?

    Das ist bei mir der Fall.

    Es ist mir bekannt, dass Fahrzeuge in den Depots nicht ansprechbar sind.

    Ich muss mir diese Sache mal genauer ansehen.


    Ein weiterer unangenehmer Nebenefekt mit den virtuellen Depots ist folgender:


    Ich habe auf der Autobahn viele Fahrzeuge fahren welche am Fahrzeugrand in einem virtuellen Depot verschwinden und nach Ablauf von 6 Sekunden wieder daraus ausfahren.

    Ich habe das auf diese Weise gelöst, weil sonst alle Fahrzeuge trotz gleicher Geschwindigkeit früher oder später als lange Schlange durch die Gegend fahren und in der Antikollisionsabfrage festhängen.

    Das Problem, welches ich hier aufführen möchte ist, dass jedesmal wenn ein Fahrzeug in das virtuelle Depot ein- oder aus-fährt, die Liste der Fahrzeuge in der Fahrzeugsteuerung verändert wird.

    Damit ist es fast unmöglich ein Fahrzeug aus der Liste auzuwählen weil sie immer wieder neu angepasst wird und die Einträge nicht ruhig stehen bleiben.

    Auch Fahrzeuge, welche nicht in die Depots fahren, können nur sehr schwer ausgewählt werden.

    Werde wohl vor den virtuellen Depots eine Weiche in den Spline einbauen müssen um die Fahrzeuge daran zu hindern in das Depot einzufahren bis die Einträge in die Kontaktpunkte erledigt ist.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.1 Expert (x64),Patch 4, PlugIns: 1; EEP 15.1 Expert(x64), Patch 2, PlugIns: 1; PlanEx 3.1; PlanEx-Easy


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.752

  • Das Problem, welches ich hier aufführen möchte ist, dass jedesmal wenn ein Fahrzeug in das virtuelle Depot ein- oder aus-fährt, die Liste der Fahrzeuge in der Fahrzeugsteuerung verändert wird.

    Hallo Karl Heinz Schmiermax ,

    das die Liste sich ständig verändert ist aber auch schon in den früheren Versionen von EEP so gewesen, irgendwann vor langer Zeit und ich weiß nicht merh in welchem Forum habe ich dazu den Hinweis gegeben, für die Auswahl eines FZ vorher die Pause-Taste zu drücken. Dann kann man in der Liste scrollen und sicher ein bestimmtes Fahrzeug / Zug auswählen.

    Gruß
    Dieter

    -----------------------------------------------------------------------------------

    Schalten und walten ist mein Hobby, aber nur in EEP ;)
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 16GB RAM, 500GB SSD, 2 TB HDD, GT 850 von Nvidia, Windows 10 Home 64bit

  • Das Problem, welches ich hier aufführen möchte ist, dass jedesmal wenn ein Fahrzeug in das virtuelle Depot ein- oder aus-fährt, die Liste der Fahrzeuge in der Fahrzeugsteuerung verändert wird.

    Das ist wohl kein Problem, es wohl eher der Tatsache geschuldet, dass das Fahrzeug schlicht und ergreifend nicht mehr auf der Anlage ist, wenn auch nur für 6 Sekunden.

    Damit ist es fast unmöglich ein Fahrzeug aus der Liste auzuwählen weil sie immer wieder neu angepasst wird und die Einträge nicht ruhig stehen bleiben.

    Was wohl auch an den von Dir aufgeführten 6 Sekunden liegen mag und sollten es mehrere virtuelle Depots geben, dann können die Einträge doch gar nicht ruhig stehen bleiben.

  • Habe das Problem mit der Fahrzeuganzeige für mich wie folgt gelöst:


    Vor der Depoteinfahrt und nach der Depotausfahrt je eine Weiche eingefügt und diese virtuell verbunden.

    Mit einem Signal stelle ich die Weiche vor dem Depot auf "Abzweig" und so fahren alle Fahrzeuge am Depot vorbei.

    Wenn das Depot ganz leer ist, sind alle Fahrzeuge in der Fahrzeugliste angezeigt und die Kontaktpunkte können ohne Probleme bearbeitet werden.

    Wenn die Bearbeitung fertig ist wird das Signal auf Fahrt gestellt und die Fahrzeuge verschwinden wieder im virtuellen Depot.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.1 Expert (x64),Patch 4, PlugIns: 1; EEP 15.1 Expert(x64), Patch 2, PlugIns: 1; PlanEx 3.1; PlanEx-Easy


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.752

  • Hallo.

    Danke für die Antworten und Hilfen.

    Habe noch keine Depots auf der Anlage platziert.

    Möchte des anhand von Bilder versuchen zu dokumentieren.



    Hier im 2 D Editor sind alle Rollmaterialien zu sehen und können auch ausgewählt werden.



    Nach Wechsel in 3 D ist im gleiche Kontakt keine Auswahl mehr angewählt.

    Manchmal ist das Feld auch weiß.



    Wird jetzt die Auswahl geöffnet ist das in 2 D vorhandene Rollmaterial nicht mehr vorhanden.

    Hat mich doch einige Stunden gekostet bis ich dahinter gestiegen bin.

    Versuche jetzt das ganze mit LUA zu lösen.

    Bleibt Gesund.

    Gruß aus Hilden

    Jochen


    Habe vergessen das nach Rückkehr in 2 D alles richtig angezeigt wird ist.

    ASUS X751LX
    Intel Core i7-5500U CPU @ 2.40GHz
    12,0GB Dual Kanal DDR3 @ 798MHz
    NVIDIA GeForce GTX 950M
    2047 MB
    Windows 10 Home 64-bit

    EEP 16.1 Expert Patch 4

  • Hallo Jochen,


    in deiner Signatur steht, 16.1 Patch 2.

    das wird sicher nicht mehr aktuell sein, könnte aber zu Irritationen führen.

    Gruß
    Dieter

    -----------------------------------------------------------------------------------

    Schalten und walten ist mein Hobby, aber nur in EEP ;)
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 16GB RAM, 500GB SSD, 2 TB HDD, GT 850 von Nvidia, Windows 10 Home 64bit

  • Hallo Dieter,


    Du hast wie immer Gut aufgepasst. Ist berichtigt. Danke.


    Gruß

    Jochen

    ASUS X751LX
    Intel Core i7-5500U CPU @ 2.40GHz
    12,0GB Dual Kanal DDR3 @ 798MHz
    NVIDIA GeForce GTX 950M
    2047 MB
    Windows 10 Home 64-bit

    EEP 16.1 Expert Patch 4

  • Habe, wie beschrieben, Probleme mit den Fahrzeugkontakten.

    Bin jetzt auf Lua umgestiegen und habe auch dort mein Probleme gehabt.

    In Lua ist der Befehl im Handbuch:

    EEPRollingstockSetSlot("Name", Slot)

    Mein Eintrag in Lua:

    EEPRollingstockSetSlot("####Flgh_Bandlader_01",2) wird nicht bearbeitet.

    Nach Änderung in:

    EEPRollingstockSetSlot("Flgh_Bandlader_01",2) funktioniert alles.


    ####Flgh_Bandlader_01 ist der Zugname, Flgh_Bandlader_01 ist der Fahrzeugname bei mir.


    Die Beschreibung von EEPSetTrainSpeed im Lua Handbuch:

    EEPSetTrainSpeed("#Name", Geschwindigkeit)


    Der Unterschied ist hier das "#'" vor dem Namen steht.

    Hier wird also nach dem Zugnamen gefragt. Ist auch von der Logik soweit richtig.

    Hat halt etwas gedauert (1 Tag experimentieren) bis ich das verstanden habe.

    Wenn in der Beschreibung Fahrzeugname stehen würde hätte es vielleicht nicht so lange gedauert.


    Lasst es euch Gut gehen und bleibt Gesund.

    Gruß

    Jochen

    ASUS X751LX
    Intel Core i7-5500U CPU @ 2.40GHz
    12,0GB Dual Kanal DDR3 @ 798MHz
    NVIDIA GeForce GTX 950M
    2047 MB
    Windows 10 Home 64-bit

    EEP 16.1 Expert Patch 4

  • Opa Joe


    Es sollte nur eine Raute vor dem Fahrzeugnamen benutzt werden.

    Mehrere Rauten führen zu Problemen bei der Namenauswertung.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.1 Expert (x64),Patch 4, PlugIns: 1; EEP 15.1 Expert(x64), Patch 2, PlugIns: 1; PlanEx 3.1; PlanEx-Easy


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.752

  • Mehrere Rauten führen zu Problemen bei der Namenauswertung.

    Hi,


    solange man z.B. bei einem Filter peinlich genau auf die Anzahl der Rauten achtet und danach mindestens ein weiteres Zeichen filtert, geht es.

    EEPRollingstockSetSlot("Name", Slot)

    Hallo Opa Joe ,

    da steht aber im Handbuch auch in der Beschreibung "Bewegt alle Achsen des genannten Rollmaterials zu den im Slot gespeicherten Positionen" und man findet es in dem Kapitel Rollmaterial-Funktionen und nicht im Kapitel Zug-Funktionen. :ae_1:

    Gruß
    Dieter

    -----------------------------------------------------------------------------------

    Schalten und walten ist mein Hobby, aber nur in EEP ;)
    __________________________________________
    EEP alle ab EEP6 mit allen Plugins,
    Homenos5, Homenos8,HomeNos11 DEV...
    Intel I7 4790k 4x 4Ghz,16 GB RAM, NVidia GTX 970 4GB, Direct x V11, Windows 7 64 Bit,
    Laptop Medion Erazer, 16GB RAM, 500GB SSD, 2 TB HDD, GT 850 von Nvidia, Windows 10 Home 64bit

  • Hallo Karl Heinz.

    Danke für die Info.


    Hallo Dieter.

    Habe ich auch "jetzt" alles verstanden.

    Sehe es auch als sinnvoll an es so zu machen.

    Das mit der Unterscheidung Rollmaterial und Zugfunktionen ist jetzt auch in mein Gedächtnis vorgedrungen.

    Ich betrachte es als Lernprozess.

    Vielen Dank für Eure Infos und Positiven Feed Backs.


    Gruß

    Jochen

    ASUS X751LX
    Intel Core i7-5500U CPU @ 2.40GHz
    12,0GB Dual Kanal DDR3 @ 798MHz
    NVIDIA GeForce GTX 950M
    2047 MB
    Windows 10 Home 64-bit

    EEP 16.1 Expert Patch 4