Ungewolltes Schaltverhalten von Weichen in Schaltkreisen

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Nach dem letzten Update-Patch hat sich das Schaltverhalten von Weichen in Schaltkreisen auf auf nicht gewollte Weise verändert. Der untere Schaltkreis wurde in EEP 16 erstellt, der Obere in EEP14 und dann in EEP16 übertragen. Hier erscheinen nun einige Splines als elektrisch die Vorher nicht elektrisch waren. Habe zuerst in EEP16 den unteren Schaltkreis überprüft, ob alle Weichen sauber schalten. Musste feststellen, dass die obere Weiche immer die darunterliegende mitschaltet. Der ober Schaltkreis funtioniert in EEP14 exakt in EEP16 aber nicht mehr. Weder bei der manuellen Schaltung noch über Steuerkontakte schaltet die Weichen richtig. Letzter Test über Steuerstraße. Ander früher erstellte Schaltkreise weisen das gleiche Fehlverhalten auf.


    Gruß, j.krae


    PS: Vielleicht ist das Verhalten von Ampeln wie bei Karlchen57 auf das gleiche Update zurückzuführen

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • Hallo j.krae


    Schön wenn Du uns noch schreiben könntest - bitte - welche Version zur Zeit in Betrieb ist - z.B. 16.2 Patch 2 ?


    LG Lothar :aq_1:

    EEP 6.1 / Konverter / EEP 13.2 Plugin 1/2 / EEP 15.1 Patch 2 - Plugin 1 / EEP 16.2 Patch 3 - Plugin 1
    Win 7 pro 64 bit
    Asus H97M-Plus , i5-4690 3.5GHz , MSI R9 290X 4GB , Kingston HyperX Blue 16GB

  • Genau, die Version 16.2 Patch2


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • hat sich das Schaltverhalten von Weichen in Schaltkreisen auf auf nicht gewollte Weise verändert

    Hallo :)


    das hängt sicher mit dem Problem: [EEP 16.2] Weichenstellung nach Update 2 vertauscht zusammen.

    Der Fehler, Weichenstellung nach Update 2 vertauscht, ist bekannt und wird zeitnah gefixt werden. Das kann allerdings ca. 1 - 2 Wochen dauern.

    Gruß Ingo

    Win 10x64 Professional, Gigabyte B360M AORUS, Intel Core i7-8700K, 32GB RAM, NVIDIA GeForce GTX 1050 Ti 4GB, 1920x1200 auf 26" TFT

    Windows Firewall und Defender
    EEP 15.1 Expert Patch 2, Plugins: 1

    EEP 16.2 Expert Patch 3, Plugins: 1,2


    alt:
    Win 7x64 Professional SP1, Intel Core i5-3570, 16GB RAM, nVIDIA GeForce GT630, 2GB, 1280x1024 auf 19" TFT

    Windows Firewall und Defender (MSE)

    EEP6; EEP8-14; EEP 15.1 Expert Patch 2, Plugins: 1

  • Hallo schlingo , nach Aufbau des Steuerkreises in EEP16 habe ich die Weichenstellungen Korrigiert. Aber, wenn ich die obere Weiche stelle und die darunter stellt sich gleichermaßen mit um und es lässt sich ständig wiederholen hängt mit dem neuesten update zusammen, zumals ich den oberen Schaltkreis aus EEP14, der dort sauber funktioniert hat, nun in EEP16 das gleiche falsche Schaltverhalten aufweist.


    Gruß, j.krae


    Nochmal EEP16.2 Patch2

    den Tag zuvor hben die Schaltkreise noch einwandfrei funktioniert.

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • Nach einer Versuchsreihe ist das Fehlerverhalten eingegrenzt. Ich zeige noch einmal die beiden Schaltkreise. Im unteren Kreis haben die 180° Bögen eine Länge von 30m, im oberen Schaltkreis eine Länge von 40m. Im unteren Kreis treten die Fehler auf, im Oberen nicht mehr.

    es hängt also stark mit der Größe des Schaltkreises zusammen. Der Effekt, das Splines plötzlich elektrisch sind wie im oberen Schaltkreis habe ich nun auch an ein paar Strassen auf der Anlage feststellen können, sollte so nicht passieren.


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • es hängt also stark mit der Größe des Schaltkreises zusammen.


    Gruß, j.krae

    Hallo j.krae

    Ich kann Deine Feststellung bestätigen.:bp_1:

    Ich habe eben auch mit den Längen der Schaltkreise experimentiert. Ich bin dabei zu dem Ergebnis gekommen das alle Schaltkreislängen unter 30 Meter nicht funktionieren.

    Über 30 Meter zeigen auch die Weichensymbole " Fahrt und Abzeig " wieder richtig angezeigt.

    mit freundlichem Gruß :aa_1: wubl

    Windows 10 - 64 Bit - 8,0 GB Speicher

    2 - AMD A6 - 6400 K - APU - HD Graphics

    NVIDIA GeForce GTX 1050 Ti

    EEP 16.2 Patch 3







  • j.krae

    es hängt also stark mit der Größe des Schaltkreises zusammen

    Hast Du mal geprüft, ob in beiden Schaltkreisen der Gleistyp beibehalten worden ist?

    In Deiner Anordnung müssten es eigentlich nur die Typen "line" und "arc" sein.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • Ja, Schmiermax , ich habe da nur line und Arc verbaut, mit Vervielfältigung Gleisestücke angesetzt oder verlängert und das korrekte andocken unter der Oberfläche vollzogen.


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • j.krae

    ich habe da nur line und Arc verbaut,

    Ist dieser von Dir verbaute Zustand erhalten geblieben oder haben sich die Splinetypen verändert?


    Gruß

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • Also Schmiermax ,

    dieser Schaltkreis wurde in EEP14 erstellt mit 30m Halbbögen:

    habe den Block in EEP16 hineinkopiert und in der EEP16-Anlage geöffnet. Das ist das Ergebnis:

    Alle line und Arc sind erhalten geblieben, aber einige Schaltkontakte und Gleiseigenschaften haben sich verändert. Aber nach der Korrektur der Kontakte und Richtigstellung vom Fahrt und Abzweig habe ich das falsche Schaltverhalten der Weichen festgestellt.


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • j.krae

    habe den Block in EEP16 hineinkopiert und in der EEP16-Anlage geöffnet.

    Mache mal einen anderen Versuch und zwar so:


    Mit EEP 14:

    setze dort den Block in eine leere Anlage ein und speichere sie dann mit einem neuen Namen.


    Mit EEP 16:

    Starte EEP 16 und lade die mit EEP 14 erstellte Anlage.

    Prüfe, ob die Weichen des Schaltkringel noch alle richtig sind.

    Markiere jetzt die Schaltkringel und speichere sie als Block ab.

    Schliesse dann diese Anlage.


    Öffne jetzt die Anlage mit EEP 16 in der dieser Block benötigt wird und füge dann den neuen Block ein.

    Überprüfe dann die Weichenstellungen.


    Ich denke, wenn Du den in EEP 14 erstellten Block nach EEP 16 kopierst, dass dann der Fehler auftritt, wie von Dir beschrieben.

    Anscheinend werden da die Spline nicht richtig transformiert.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • Schmiermax , ich habe diesen Sch áltkreis auf einer leeren Anlage in EEP16 erstellt, nur line und arc und alle linken Weichen stehen so auf Fahrt.

    Stelle ich Weiche 9 auf Abzweig, schaltet 7 mit, genauso 7 mit 5, 5 mit 3. nur bei 3 bleibt 1 auf Fahrt stehen.

    alle Halbbögen haben 30m, die Weichen 10m.

    Hier noch die 3D Ansicht.


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • j.krae


    Ich werde das mal bei mir versuchen und gebe Dir dann Bescheid.


    Gruß

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • j.krae


    Ich habe Deine Schaltkringel mal nachgebaut und ich kann den Fehelr bestätigen.

    Auch bei mir wechseln immer zwei Weichen gleichzeitig die Posiotion obwohl nur eine geschaltet wird.


    Habe als Gleis den Strassenbahn-Spline "Normal" genommen.


    Wenn die geraden Weichenantriebe von 10 auf 20m verlängert werden tritt der Fehler nicht mehr auf.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • Genauso bei mir Strassenbahnspline normal und auch normal2.


    Fehler wurde auch schon in #7 von wubl58 bestätigt.


    schlingo , wann wird der Fehler offiziell als solcher kundgetan!


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • j.krae


    Noch ein Hinweis.

    Wenn die Weichenantriebe vorwärts kopiert werden bevor der zweite Schenkel angedockt wird dann tritt der Fehler nicht auf.

    Wenn der abbiegende Schenkel erst angedockt wird und dann der Weichenantrieb vorwärts kopiert wird tritt der Fehler wieder auf.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • Der in #13 erstellte Schaltkreis wurde so erstellt, dass ich das erste Weichenstück links und rechts nach vorwärts kopiert habe, den Halbbogen auch vorwärts kopiert, in 3D dann an den Andockpunkt der ersten Weiche nach vorwärts geschoben. Die gleiche Prozedur ging dann bei den anderen Weichen und Gleisen so weiter, immer an der vorletzten Weiche angedockt.


    Die Schaltkreise wo der Halbogen eine Länge von 40m hat, zeigen dieses Fehlverhalten nicht mehr.


    Gruß, j.krae

    IntelCore i7-4790 3,6GHz,16GB,GTX960 4GB,Win10-64Pro HD: 200GB+1TB für Sohn EEP 6,10,13,14,16

    Lapt.HP17 i7950H 2,6GHz,16G-Ram, GTX1650, Win10 Home 64, 256G-SSD,1TB-HD, Netbook 10",2GB Ram,320GB-HD, Win10-32

    IntelCore i5-3570 3,8GHz,16GB-Ram, GTX970, W.10Pro64 > SSD 120G, 2TB-HD, LCD Asus 22+19" - EEP6,10-16

    Train-Sim,Mod.-expl.,-kat., -konv.,Zug-Explorer,MET,Bilderscanner

    Home-Nos13,Blender 2,79,Makehum. <lernen

    Motto: Es gibt keine Probleme, nur Aufgaben


    Sonst: Alllroundhandwerker, PC-Doktor, EEP-Fan

  • j.krae


    In welcher Reihenfolge auch die Spline verlegt werden, der Fehler sollte eigentlich nicht auftauchen.


    Wird auf einen erneuten Patch hinaus laufen.


    Viele Grüße

    Karl Heinz

    Benutzte Programme: EEP 16.2 Expert (x64),Patch 3, PlugIns: 1,2


    Notebook Dell Inspiron 7720; Intel Core(TM) i7 - 3630QM CPU 2,4/3,8 GHz; 16 GB RAM, nVidia GeForce GT 650 M (2 GB)
    Windows 10 Home - 64 Bit, Version 1909, Betriebssystembuild 18363.836

  • wann wird der Fehler offiziell als solcher kundgetan!

    Hallo :)


    entweder wenn Du ihn im EEP Bugtracker einträgst. Eine Alternative ist hier genannt. Bitte dabei auch das beachten.


    Gruß Ingo

    Win 10x64 Professional, Gigabyte B360M AORUS, Intel Core i7-8700K, 32GB RAM, NVIDIA GeForce GTX 1050 Ti 4GB, 1920x1200 auf 26" TFT

    Windows Firewall und Defender
    EEP 15.1 Expert Patch 2, Plugins: 1

    EEP 16.2 Expert Patch 3, Plugins: 1,2


    alt:
    Win 7x64 Professional SP1, Intel Core i5-3570, 16GB RAM, nVIDIA GeForce GT630, 2GB, 1280x1024 auf 19" TFT

    Windows Firewall und Defender (MSE)

    EEP6; EEP8-14; EEP 15.1 Expert Patch 2, Plugins: 1