Vorschaufenster für Splines möglich? (gelöst)

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Hallo,


    eigentlich benutze ich nicht sehr viele verschiedene Typen, so dass ich eine Vorschau noch nicht vermisse. Bei Brücken, Mauern, S-Bahnen oder Tunneln hätte ich aber schon gerne mal gesehen, was ich da einbaue. Es gibt zwar ein Werkzeug für Splinevorschau und ich hatte gehofft, dass dieses mir ein Aufklappfenster in eep installiert - das geschieht aber nicht. Kann man sich ein Vorschaufenster für Splines in eep5 einrichten?


    Auf 6.1 habe ich noch nicht gewechselt, weil ich noch Schaltungsprobleme vorher lösen möchte und ich keine Lust auf Leerlauffrust habe, falls die Übernahme fehlschlägt. Später, wenn tausende mehr Splines möglich sind, möchte ich die schon vorher sehen können. Die jetzigen 10 oder 20 kann ich mir noch merken. Hat 6.1 das vielleicht automatisch eingebaut?


    Bubikopf

  • Eine eingebaute Spline-Vorschau gibt es erst ab EEP7.

    Aber für die niedrigen Versionen gibt es von EF1 ein Tool namens "Gleisstile-Vorschau für EEP", das dir ein entsprechendes Vorschaufenster anzeigt (bzw. anzeigen sollte).

    Das Tool von EF1 kann nur vorhandene Bilder anzeigen. Um entsprechende Bilder zu erzeugen, habe ich vor langer Zeit ein weiteres Tool geschrieben, die "Splinevorschau". Dieses Tool ist noch auf der Seite von Waldemar erhältlich. Vielleicht hattest du dieses Programm schon gefunden?

    Ohne das Tool von EF1 ist mein Tool zugegebenermaßen etwas nutzlos...


    Viele Grüße

    Benny

  • Genau dieses Tool habe ich verwendet. Es erzeugt mit Irvanview offenbar alle Vorschaubilder - man sieht, wie sie erstellt werden -, aber nach Beendigung des Vorgangs passiert nichts. Nur eine Anlage namens „Spline-Vorschau“ bleibt übrig, aber ohne Fensterchen. Es darf auch kein Spline-Fehler vorhanden sein, sonst hängt sich das Programm auf. Heißt das, das war nur quasi „die erste Häjfte“ des Vorgangs...? Wo liegen die Vorschaubildchen?


    Edit: ich habe tatsächlich das Programm von E. Fasswald gar nicht benutzt! Ich habe nicht gewusst, dass man BEIDE Programme brauchte, sondern geglaubt, das eine wäre nur eine Alternative zum anderen... Schließlich haben die ähnliche Namen...


    Tatsächlich gibt es jetzt ein Fensterchen mit Vorschaubildern. Leider sind diese schwer erkennbar.

    Ich müsste den Vorschaubildprozess nochmal mit besserem Hintergrund ablaufen lassen, damit man die Splines auch sieht.


    Spline-Vorschau.jpg

  • Genau, lass die Vorschaubild-Erstellung nochmal laufen. Eigentlich sollte diese spezielle Vorschau-Generierungs-Anlage nichts als einen gelben Hintergrund zeigen (keine Ahnung, was ich mir damals bei dieser Farbe gedacht habe :af_1:).

    Entweder ist in deinem Fall noch die Geländeoberfläche in schwarz zu sehen (warum auch immer!?), oder irgendein großer schwarzer Spline, der zuvor eingesetzt wurde und bei dem das Löschen dann aus irgendeinem Grund nicht geklappt hat (wahrscheinlicher).

    Zumindest letzteres Problem solltest du durch Neugenerierung aller betroffenen Bilder beheben können.


    Viele Grüße

    Benny


    PS: Ein Blick in die Anleitungen ist auch nicht verboten, die eine oder andere Frage ist dort schon beantwortet :ae_1:

  • Habe in der Spline-Vorschau-Datei die Kamera anders eingestellt und versucht, den Boden mit Schnee zu weißen, aber das schwarze Dinge geht nicht weg. Beim zweiten Durchlauf ist jetzt auch gar nichts angekommen. Die Bilder waren aber im Ordner, nur nutzen sie mir so kaum etwas.


    PS: die Gleise werden automatisch mit 0,66 m Höhe eingesetzt, was z.B. bei Bahndämmen nichts bringt, da das schwarze Feld den Damm darunter abdeckt.


    Ich probier's nochmal...

  • Ich habe es noch mal runtergeladen, neu installiert und durchlaufen lassen - siehe da:


    Spline-Vorschau-korrekt.jpg


    Jetzt nur noch die Position nach links oben anpassen...


    Wie konnte ich bloß ohne das leben..? ;)


    PS Offenbar ist das schwarze Ding nicht die Landschaft, sonst lägen die Gleise ja oben drauf und ich hätte sie besprühen können. Ich glaube auch, dass es irgendso ein flächiger Immobilienhai oder eine Wunder-Textur war, hervorgerufen durch falsche '.defs oder so.


    Super ist auch, dass darin sofort die Gleiskörperhöhe abzulesen ist. Da ich häufig Nivellierungsprobleme habe, ist das hilfreich!