Unerwartete Programmreaktionen im 2-D Planfenster

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Guten Abend zusammen,


    wenn ich versuche im 2-D Planfenster Objekte (Landschaftselemente, Immobilien etc. zu editieren will (nur bei neueren Anlagen unter EEP 16) erscheinen folgende Bildschirme, die ich als Bilder angehängt habe:

    Zur Erläuterung:


    Beim ersten Linksklick erscheint ein grau schraffierter Bildschirm


    Bein zweiten Linksklick erscheint der grau schraffierte Bildschirm mit Signalen und Fahrzeugen


    Und beim 3. Klick - Rechtsklick erscheint der Bildschirm mit den Eigenschaftsfenster - aber nich für das angeklickte Objekt sondern immer ein Fahrleitungsmast (DD 2m5) oder z.B. "Veranda 1A_zwischen_LD1" mit kryptischen Eigenschaften!


    Wer hat sowas schon einmal gehabt, woher kommt das und wie man bekommt die Bugs? wieder weg?


    Die Anlage in 3D mit Lua gesteuert, funktioniert ohne Probleme.


    Vielen Dank im Voraus


    kervi

  • Ich meine, dass Du irgendwo ein skaliertes Modell auf der Anlage hast, welches wahrscheinlich ausversehen skaliert worden ist. Ich hatte das auch schon öfters... wollte ein Modell verschieben und habe irgendwie die Skalierfunktion erwischt.

  • Die ganzen "nan"s (das steht für "Not a Number", also "Keine Zahl") im Eigenschaftenfenster deuten darauf hin, dass mit diesem Objekt irgendwas gehörig schiefgegangen ist. Das kriegt man nicht durch normales Skalieren hin.


    Ansonsten hat icke aber Recht: Es gibt ein Modell mit riesigen Ausmaßen auf deiner Anlage. Sobald du irgendwo hinklickst, wird dieses Modell markiert. Beim Rechtsklick siehst du die Eigenschaften dieses Modells.

    Am einfachsten wirst du das Problem los, indem du das Modell löschst: Markieren (lässt sich beim irgendwo-hinklicken ja gar nicht vermeiden) und Entf drücken.



    Viele Grüße

    Benny

  • Hallo,


    wenn man das 3.Bild so weit vergrößert, daß man die "Werte" in den Eigenschaftsfeldern lesen kann, sieht man, das fast überall "nan" oder "-nan(ind)" steht. Was heißt im EEP-Programmierer-Sprech "nan"? Für mich scheint dieses Element "DB 2m5" Eigenschaftswerte jenseits von Gut und Böse, bzw. jenseits der vom Programm darstellbaren Werte zu haben.


    Wie sowas passieren kann? Weiß nicht, aber die Programmierer wissens vielleicht....


    Gruß

    Gerhard


    Edit:

    Benny war schneller und hat sogar ne Erklärung für "nan":be_1:

    i7-7800X (12x 4GHz), 32GB RAM | GeForce GTX 1080, 8GB RAM
    Win7Pro SP1:

    EEP12.1 (PI1), EEP13.2 (PI1&2), EEP14.1 (PI1), EEP15.1, EEP16.2 (PI1)

    Win10Pro (v2004):

    EEP16.4 (PI1,2,3)

  • Hallo kervi,

    Ich hatte so ein ähnliches Problem. Das Objekt war nicht zu sehen. Nach mehreren erfolglosen Löschversuchen bin ich unter die Oberfläche gegangen und konnte es markieren und entfernen.


    Bleib gesund

    Rainer

    MfG Rainer


    PC: AMD Ryzen3, 4x3.5GHz, 16GB DDR4-RAM, Radeon Vega8, Win10 Home 64bit

    EEP 6,8,11,12;14,15, TM,Höhengenerator,


    Der krumme Baum lebt sein Leben.Der gerade Baum wird ein Brett.