Unschönes Phänomen in EEP16 beim Schließen der Anlagen

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
In the case of pictures that are attached to the article, the source must also be stated. This also applies to your own pictures, which were taken by you. Pictures without source information will be deleted!
  • Es gibt da einen unschönen Effekt beim Schiessen der Anlagen in EEP16, der sich bei Gelände Vergrösserung bzw. Verkleinerung gravierend auswirkt.

    Und zwar tritt folgendes auf:

    Ich beende die Anlage, nachdem ich diese ordnungsgemäß gespeichert habe. Dann beende ich EEP16

    Dabei kann es auftreten dass EEP sich nicht mehr beenden lässt und im Modus Terrain Update hängen bleibt. Warum auch immer. Es scheint auch so dass die vorher geladene Anlage nicht vollständig entladen wurde. (Arbeitsspeicher bedarf noch relativ hoch)

    Das ist so erstmal nicht schlimm, Ich kille dann den Prozess im Taskmanager. Dieser Fehler tritt übrigens häufiger auf wenn mann an der Anlage umfangreiche Änderungen gemacht hat.


    Nun aber folgendes. Ich verändere die Grösser der geladenen Anlage (größer oder kleiner egal)

    Bei der Anlagenvergösserung wird die bestehende Anlage automatisch geschlossen und mit den neuen Grössen wieder neu geladen.

    Nun lässt sich offensichtlich, aufgrund des selbigen Fehlers, mutmasslich die Anlage nicht schliessen, und somit auch nicht mit den neuen Grössen laden, was zur Folge hat das der Prozess auch dort hängt.

    Was jetzt allerdings blöd ist, weil ich die geänderte Anlage selbst auch nicht speichern kann. Ich vermute das die Funktionalität GRössenänderung soweit funktionert hat aber der abschliessende Prozess des Neuladens fehlschlägt.


    Vielleicht habt ihr das auch schon beobachtet.


    Abhilfe konnte ich schaffen in dem ich eine editierte Anlage speichere und EEP vollständig schliesse. Dann EEP neu starten und die Anlage neu Laden und dann nur die Anlagengrösse ändere, dann sofort speichern.

    Betriebssystem: Windows 7 Ultimate N 64 Bit (inkl. Media Pack)

    Arbeitsspeicher: 32 GB RAM

    Prozessor: Intel(R) Core(TM) I5-2320 CPU 3GHz

    Grafikkarte - Zotac Geforce GTX 1050 ti - 4GB

    Motherboard: Asus P8H67-M PRO mATX Mainboard Sockel LGA1155

    Festplatte: SSD: 128 GB

    EEP 14.1, 16.4 (Plugin 2)

  • kann es auftreten dass EEP sich nicht mehr beenden lässt und im Modus Terrain Update hängen bleibt. Warum auch immer. [...]

    Hallo Ulrich :)


    da bist Du nicht alleine. Auch ich beobachte diesen Effekt in letzter Zeit öfter. Die Ursache kennen wir bisher nicht. Möglicherweise liegt es an der Größe und/oder Komplexität der Anlage, siehe z.B. Instabilität von EEP bei großen Anlagen.

    Das ist so erstmal nicht schlimm, Ich kille dann den Prozess im Taskmanager.

    Hier reicht es, in EEP (erneut) Alt-F4 zu drücken. Statt den Prozess abzuwürgen, wird die Anlage dann ordnungsgemäß geschlossen und ich kann anschließend auch EEP sauber beenden.

    Vielleicht habt ihr das auch schon beobachtet.

    Ich habe zwar schon länger keine Größenänderungen mehr durchgeführt, aber bisher keinen Fehler durch diesen Effekt festgestellt. Versuche doch einmal wie ich, die Anlage und EEP ordnungsgemäß zu schließen (siehe oben) statt den Prozess zu killen. Hilft das?


    Gruß Ingo

    Threema - Sicherer und privater Messenger

    Meine Threema-ID

    Warum Threema?


    Win 10x64 Professional, Gigabyte B360M AORUS, Intel Core i7-8700K, 32GB RAM, NVIDIA GeForce GTX 1050 Ti 4GB, Philips 273V7QDAB Full HD

    Windows Firewall und Defender
    EEP 15.1 Expert Patch 2, Plugins: 1

    EEP 16.4 Expert, Plugins: 1,2,3,4


    alt:
    Win 7x64 Professional SP1, Intel Core i5-3570, 16GB RAM, nVIDIA GeForce GT630, 2GB, 1920x1200 auf 26" TFT

    EEP6; EEP8-14; EEP 15.1 Expert Patch 2, Plugins: 1

  • Versuche doch einmal wie ich, die Anlage und EEP ordnungsgemäß zu schließen (siehe oben) statt den Prozess zu killen. Hilft das?

    Ja natürlich, wenn das geht ist das besser als den Prozess zu killen aber das Problem der Veränderung der Anlagengrösse ist damit nicht behoben, weil da habe ich ja keinen Einfluss drauf. EEP will nach der Grössenveränderung die Anlage schliessen und Neuladen und das funktioniert nicht mehr. Ich habe keine Möglichkeit dazwischen zu gehen und die Veränderung zu speichern, denn dafür muss die Anlage erst wieder neu geladen sein und dieser Prozess findet ja unter der Haube von EEP statt.

    Betriebssystem: Windows 7 Ultimate N 64 Bit (inkl. Media Pack)

    Arbeitsspeicher: 32 GB RAM

    Prozessor: Intel(R) Core(TM) I5-2320 CPU 3GHz

    Grafikkarte - Zotac Geforce GTX 1050 ti - 4GB

    Motherboard: Asus P8H67-M PRO mATX Mainboard Sockel LGA1155

    Festplatte: SSD: 128 GB

    EEP 14.1, 16.4 (Plugin 2)

  • Also es ist auch nur eine Vermutung von mir das beide Effekte die gleiche Ursache haben.

    Betriebssystem: Windows 7 Ultimate N 64 Bit (inkl. Media Pack)

    Arbeitsspeicher: 32 GB RAM

    Prozessor: Intel(R) Core(TM) I5-2320 CPU 3GHz

    Grafikkarte - Zotac Geforce GTX 1050 ti - 4GB

    Motherboard: Asus P8H67-M PRO mATX Mainboard Sockel LGA1155

    Festplatte: SSD: 128 GB

    EEP 14.1, 16.4 (Plugin 2)

  • Hier mal ein Beispiel warum mich dieser Fehler in den Wahnsinn getrieben hatte.


    Ich habe eine sehr, sehr, große Anlage die ich Aufgrund der hohen Belastung in EEP16 um die Hälfte reduzieren wollte. Da die Anlage ohnehin mehr oder Weniger aus zwei getrennt programmierten Teilen bestand was das soweit ohne Probleme umzusetzen.

    Die Anlage war bereits über 70MB groß und dlie Ladezeit lag bereits bei etwa 35 Min.

    Nun habe ich begonnen die Anlage erstmal von links aus abzuräumen. Immer wieder zwischen gespeichert, darauf habe ich gleich geachtet

    Als ich aus meiner Sicht alle Objekte auf der linken Seite entfernt hatte wollte ich die Anlage dann von 12,4 km auf 6km links reduzieren.

    Aber in der Realität war es dann so dass ich doch nicht alle Objekt abgeräumt hatte und ich immer nur vielleicht 300m reduzieren konnte EEP hat die Grössen änderung automatisch angepasst. Wenn es den Vorgang mit einer Warnung abgebrochen hätte wäre es besser gewesen und ich hätte noch mal prüfen können. so wollte EEP nur 300m reduzieren und der Prozess hing. Also wieder noch mal von vorn neu laden 30 min warten. Dann die Objekte prüfen. Ja bei 300m hing da noch ein Bäumchen. Objekt gelöscht Anlage gespeichert. nächster Versuch. Wieder nur 600m, da war noch ne Mauer. Dann habe ich Schrittweise Quasi Meter für Meter die Anlage reduziert immer gespeichert und die Anlage geschlossen, Neu geaden immer wieder 30 min gewartet, später hat sich ja die Zeit reduziert, aber 10 min waren es immer. Ich habe da den ganzen Tag dran gesessen, aber nur weil ich immer wieder die Anlage neu laden musste.


    Das hat mich doch zu Verzweiflung gebracht. Am Ende habe ich die Anlage erfolgreich auf die Hälfte reduziert. Leider mit dem Ergebnis, das die Perfomance nicht besser geworden ist. Aber das ist ein anderes Teema

    Betriebssystem: Windows 7 Ultimate N 64 Bit (inkl. Media Pack)

    Arbeitsspeicher: 32 GB RAM

    Prozessor: Intel(R) Core(TM) I5-2320 CPU 3GHz

    Grafikkarte - Zotac Geforce GTX 1050 ti - 4GB

    Motherboard: Asus P8H67-M PRO mATX Mainboard Sockel LGA1155

    Festplatte: SSD: 128 GB

    EEP 14.1, 16.4 (Plugin 2)

  • in der Realität war es dann so dass ich doch nicht alle Objekt abgeräumt hatte und ich immer nur vielleicht 300m reduzieren konnte [...] Dann die Objekte prüfen. Ja bei 300m hing da noch ein Bäumchen. Objekt gelöscht Anlage gespeichert. nächster Versuch. Wieder nur 600m, da war noch ne Mauer.

    Hallo Ulrich :)


    hilft Dir zwar bei Deinem Problem nicht. Aber warum hast Du denn nicht in 2D eine entsprechend kleine Zoomstufe eingestellt und anschließend einen Layer nach dem anderen geöffnet, den gesamten Bereich markiert und die Entf-Taste gedrückt? So kannst Du sehr schnell alle Objekte entfernen. Ausnahme sind natürlich Splines, auf denen sich noch Signale und/oder KP befinden.

    16.3 Patch 2 (Plugin 2)

    Hast Du wirklich noch kein Update 4?


    Gruß Ingo

    Threema - Sicherer und privater Messenger

    Meine Threema-ID

    Warum Threema?


    Win 10x64 Professional, Gigabyte B360M AORUS, Intel Core i7-8700K, 32GB RAM, NVIDIA GeForce GTX 1050 Ti 4GB, Philips 273V7QDAB Full HD

    Windows Firewall und Defender
    EEP 15.1 Expert Patch 2, Plugins: 1

    EEP 16.4 Expert, Plugins: 1,2,3,4


    alt:
    Win 7x64 Professional SP1, Intel Core i5-3570, 16GB RAM, nVIDIA GeForce GT630, 2GB, 1920x1200 auf 26" TFT

    EEP6; EEP8-14; EEP 15.1 Expert Patch 2, Plugins: 1

  • Hallo Ingo und guten Morgen. Meistens hingen die Objekte an den Anlagenrändern, die hatte ich dann beim markieren nicht erwischt. Und natürlich diverse Splines mit Kontaktpunkten oder Signalen, die kann man nicht im Block erfassen. Ja es ist ein bisschen Übungssache. Jetzt bin ich auch schlauer.


    Übrigens, Du hast recht. Ich habe bereits Update 4, nur die Plugins 3 und 4 habe ich mir nicht mehr zugelegt. Ich werde meine Signatur ändern.


    Gruß Ulli

    Betriebssystem: Windows 7 Ultimate N 64 Bit (inkl. Media Pack)

    Arbeitsspeicher: 32 GB RAM

    Prozessor: Intel(R) Core(TM) I5-2320 CPU 3GHz

    Grafikkarte - Zotac Geforce GTX 1050 ti - 4GB

    Motherboard: Asus P8H67-M PRO mATX Mainboard Sockel LGA1155

    Festplatte: SSD: 128 GB

    EEP 14.1, 16.4 (Plugin 2)