Falsches Verhalten bei Anwendung bei Splinen von "Fahrt und Abzweig tauschen" in Verbindung mit Fahrstraßen

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
In the case of pictures that are attached to the article, the source must also be stated. This also applies to your own pictures, which were taken by you. Pictures without source information will be deleted!
  • Hallo,

    folgender Fehler in EEP 17.2, Patch 1, PlugIn 1,2 ist mir aufgefallen.

    Bei Weichen, bei denen der Befehl "Fahrt und Abzweig tauschen" abgewandt und danach Fahrstraßen angelegt wurden, wird diese Einstellung nicht mehr beibehalten wenn ein Weichenantrieb erneut bearbeitet werden muss.

    Das erneute Bearbeiten war nötig um die Weichenlaternen an den Weichen auszublenden. Sobald die Änderung abgeschlossen wird nimmt der Weichenantrieb die ursprüngliche Stellung ein und die vorherige Einstellung wird ignoriert.

    In der Fahrstraße bleibt die Stellung erhalten welche beim Anlegen derselben eingestellt war.

    Das hat zur Folge, dass der Zug bei aktivierter Fahrstraße an der Stelle mir der falsch gestellten Weiche von seiner Richtung abweicht und somit die Zielfahne nicht erreicht.

    Eigentlich müsste bei der Anwendung von "Fahrt und Abzweig tauschen" diese Einstellung auch erhalten bleiben wenn der Weichenantrieb in irgend eine Weise nachbearbeitet werden muss.


    Da ich sehr viele Fahrstraßen in meiner Anlage angelegt habe, und durch den beschriebenen Umstand viele Weichen nicht mehr die Stellung der Fahrstraße haben, müssen alle Fahrstraßen kontrolliert und die falsch gestellten Weichen erneut durch "Fahrt und Abzweig tauschen" in die Richtige Stellung gebracht werden.

    Mit dem Tauschmanager von HStoni54 wurden bei den Fahrstraßen, welche falsch gestellte Weichen enthielten, diese als Fehler erkannt.

    Die Korrektur brachte aber nicht das erwartete Ergebnis. Es wurde zwar dann kein Fehler mehr erkannt, aber die meisten Weichen wichen immer noch von den Vorgaben in den Fahrstraßen ab.

    Es bleibt also nur alle Fahrstraßen abzufahren und die betroffenen Weichenstellungen zu korrigieren.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

  • Schmiermax February 7, 2024 at 6:44 PM

    Changed the title of the thread from “Falsches Verhalten bei Anwendung von "Fahrt und Abzweig tauschen" in Verbindung mit Fahrstraßen” to “Falsches Verhalten bei Anwendung bei Splinen von "Fahrt und Abzweig tauschen" in Verbindung mit Fahrstraßen”.
  • Hallo,

    hat da niemand etwas dazu zu sagen oder habt ihr damit keine Probleme?


    Ich finde, dass das eine großer Fehler in EEP ist. Eigentlich müsste die einmal gewählte Einstellung an den Weichenantrieben erhalten bleiben, auch wenn ich den Weichenantrieb erneut anfasse, und nicht in die von EEP vorgegebene Einstellung.

    Man kann sich mit diesem Verhalten ganze Fahrstraßensteuerungen kaputt machen und das ist eigentlich nicht das Ziel.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

    Edited once, last by Schmiermax (February 8, 2024 at 3:17 PM).

  • Hallo Karl Heinz.

    Bei den GK3 Weichen, die ich nur noch verwende, hatte ich dieses Problem noch nicht. Mittlerweile bleibt ja auch die Fs bestehen wenn man eine Weiche verschiebt

    Grüße aus Nordhessen:ae_1:

    Michael


    EEP 16.4 Expert, Plugin 1,2,3.

    EEP 17.2 Plugin 1, 2

    PC: Win 10 Prof. 64 Bit , AMD 8X3,2GHz. 32GB RAM. 8GB GB Radeon RX 570

    Laptop: Win 11 Home, ACER Nitro5 mit AMD Ryzen7 3,2Ghz bis 4,4 Ghz, DDR4 16Gb 32Gb, RTX 370 Grafikkarte 8 GB:be_1:

  • Michel25

    Hallo Michael,

    ich kann die GK3 Weichen in den meisten Fällen nicht benutzen weil der originale Plan der Anlage das nicht zu lässt. Da sind Weichen dicht hintereinander und dafür sind die vorgefertigten Teile einfach zu groß. Auch sind viele Weichen in gebogenen Gleisen mit unterschiedlichen Radien.

    Um komplett auf das GK3 System umzustellen müsste ich die gesamte Gleisanlage neu aufbauen und das ist mir nach fünf Jahren Arbeit an dieser Anlage einfach zu viel.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

  • Hallo Karl Heinz Schmiermax


    Ich habe das problem noch nicht gehabt weil bei mir die Weichenlaternen noch nicht weg sind. Das muss noch passieren. Dein Bericht macht mir also sorgen fuer "MORGEN" weil es bei mir auch soweit kommt.


    Also ich habe es bei mir schnell getestet fuer ein Weiche und JA ich habe das gleiche Problem. Also es ist ein Fehler die mir dazu bringen will die Weichenlaternen vorlaeufig nicht zu eliminieren.


    Ich hoffe deswegen das jemand der EEP-programmer das beheben kann.


    Ich fuerchte Karl Heinz das unsere Arbeitsweise, die Laternen da zu lassen zur Kontrolle bis alle FS programmiert sind und erst dann zu loeschen, nicht oft benuetzt wird. Oder mann benuetzt nur noch GK3 Weichen.

    Ich weiss leider auch nicht ob es mit Lua ein Problem gibt.

    Vielleicht deswegen wenig Kommentare aber es ist und bleibt ein Fehler.

    Grusse von einem Niederlander in Belgien

    Ad

    Windows11 64bit operating system

    EEP15, patch2, EEP17.1

    Model Files Converter 1.3.7, Modell-Katalog, Modell-Explorer, Anlagenverbinder, HomeNOS-15

    MSI Gaming GF65 10SDR 10750, Intel 6 Core i7-10750H CPU @ 2.60GHz, Memory 32Gb DDR4 RAM

    500 Gb Samsung SSD, 1000 Gb HDD ACER,

    NVIDIA GEFORCE GTX1660 Ti, Memory 6Gb (fix) + 8Gb (overlay),

  • Hallo Karl Heinz ( Schmiermax ),

    hat da niemand etwas dazu zu sagen oder habt ihr damit keine Probleme?

    das Problem, dass bereits verlegte Weichen beim erneuten Anklicken die Fahrtrichtungen spontan und ohne Info ändern habe ich schon.
    Und da hilft es mir wenig, wenn diese Änderung im KP übernommen wird (da ich nicht so viele EEP-Fahrstraßen verwende, lieber eigene, ist mir das dort noch nicht aufgefallen), aber jede Lua-Steuerung, die die Weiche verwendet, versagt danach.
    Und ich habe mich schon immer gefragt, warum EEP so einiges bei bereits verlegten Fahrwegen meint nachträglich ändern zu müssen, wenn man drauf klickt.
    Könnte man sich nichts (ohne jedes Stück Fahrweg sperren zu müssen) einfallen lassen, dass bereits verlegte Objekte von dem Anpassungs-Automatismus ausgenommen werden.

    Nur ich benutze halt noch EEP 15 und kann darum zur Version 17 nichts sagen.

    Jürgen

    EEP: 12.1, 13.2, 14.1, 15.1, 16.4 (z.Zt. installiert aber nur für Tests im Einsatz)

    keinerlei externe Zusatztools und manuell manipulierte Anlagendateien

    Prozessor: Intel(R) Core(TM) i5-4460S CPU @ 2.90 GHz 2.90 GHz
    PC: RAM 12 GB, Windows 10 Home, 64 Bit
    GK: NVIDIA Geforce GT 730, 4 GB

    Edited once, last by JuergenSchm (February 8, 2024 at 5:12 PM).

  • AdvEe

    Ich weiss leider auch nicht ob es mit Lua ein Problem gibt.

    Hallo Ad,

    wenn Du mit Lua Weichen schaltest dann fährt der Zug nicht mehr in die eigentlich vorgesehene Richtung.

    Das betrifft eigentlich jede Steuerung in denen Fahrstraßen und Weichen gesteuert werden.


    Bei mir ist es so, dass alle Weichenlaternen ausgeblendet sind und ich jetzt alle Fahrstraßen überprüfen muss.

    Da sind nicht wenige Weichen in der falschen Stellung und ich muss das jetzt korrigieren.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

  • JuergenSchm

    Nur ich benutze halt noch EEP 15 und kann darum zur Version 17 nichts sagen.

    Hallo Jürgen,

    soweit ich mich erinnern kann ist das bei allen EEP- Versionen der Fall. Hatte das Problem auch früher schon.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

  • Nicci 53

    Hallo Rudi,

    könntest Du mal bei den Programmierern nachhaken ob der Fehler wie oben beschrieben irgendwie beseitigt werden kann.

    Das ist nämlich sehr ärgerlich weil dadurch ganze Steuerungen durcheinander kommen und es sehr viel Arbeit macht das alles wieder zu berichtigen.

    Ich bin mir sicher, dass ich nicht der Einzige bin der damit Probleme hat. Das ist vielleicht auch der Grund warum hier im Forum immer wieder Beiträge auftauchen mit "Gestern hat noch alles gut funktioniert und heute nicht mehr".

    Wenn man bei den Weichenantrieben "Fahrt und Abzweig tauschen" benutzt, dann muss diese Einstellung auch erhalten bleiben wenn man den Weichenantrieb neu bearbeitet oder manchmal nur unbewusst anfasst.

    Ich wäre sehr dankbar wenn da was zu machen wäre.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

  • Das wird auch daran liegen das EEP bei einer Weiche immer den ersten angelegten Strang als gerade einstuft. Egal ob es am Abzweig ist oder nicht. Also immer erst den geraden Strang ansetzen

    Grüße aus Nordhessen:ae_1:

    Michael


    EEP 16.4 Expert, Plugin 1,2,3.

    EEP 17.2 Plugin 1, 2

    PC: Win 10 Prof. 64 Bit , AMD 8X3,2GHz. 32GB RAM. 8GB GB Radeon RX 570

    Laptop: Win 11 Home, ACER Nitro5 mit AMD Ryzen7 3,2Ghz bis 4,4 Ghz, DDR4 16Gb 32Gb, RTX 370 Grafikkarte 8 GB:be_1:

  • Hallo Schmiermax ,

    das ist in dem Sinne kein Fehler, auch wenn ihr den so wahr nehmt. Das Problem ist dass EEP jedes Mal wenn man an der Weiche rum fummelt die Weiche programmtechnisch neu zusammensetzt, insbesondere natürlich wenn man die Weichenlaterne "verschiebt". Ich habe es jetzt gerade nicht ausprobiert, aber z.B. eine virtuelle Verbindung an der Weiche müsste auch verloren gehen wenn man die Einstellungen für die Weichenlaterne ändert. Wenn ich nun die Funktion "Fahrt/Abzweig tauschen" ausführen, dann schiebt das Programm einfach in der Anlagendatei die entsprechenden Infos hin und her, es ist aber für EEP hinterher nicht mehr erkennbar, dass die entsprechende Funktion an dieser Weiche ausgeführt worden ist. Ergo kann das auch nicht bei weiteren Nacharbeiten dann dort berücksichtigt werden oder man müsste halt die Anlagendatei (unnötigerweise) um solche eine Information ergänzen, was aber auch wieder Inkompatibilitäten zu älteren Programmständen nach sich zieht.

    Michel25
    Nach meinem Kenntnisstand ist die Logik dahinter doch etwas komplizierter als nur 1. und 2. Strang, dein Hinweis ist daher etwas mit Vorsicht zu genießen.

    Gruß Michael

    35098-katalog-banner-jpg

    Hardwarekonfiguration:
    Laptop: Lenovo IdeaPad Gaming 3, Ryzen 5 5600H, 32GB RAM, Win11 64 bit, EEP 6.1/EEP 17.2 Expert DEV

  • Michael89

    Hallo Michael,

    vielen Dank für Deine Erklärung.

    Ich bin trotzdem der Meinung dass da was geändert werden müsste weil es zu sehr vielen Fehlern bei der Steuerung der Anlagen führt.

    Eigentlich müsste nur die automatischen Bearbeitung der Weichenantriebe blockiert werden wenn man Fahrt und Abzweig getauscht hat oder es muss anders gewährleistet werden damit diese Änderung erhalten bleibt.

    Wenn man nur eine kleine Anlage mit wenigen Weichen hat kann man das noch klaglos hinnehmen, bei größeren Anlagen mit komplizierten Steuerungen aber nicht mehr.

    Viele Grüße

    Karl Heinz

    Benutzte Programme und Hardware

    EEP 17.2 Expert [x64], Patch 1, PlugIn 1, 2

    HomeNos 17.0

    Tauschmanager, Model Multiplier, Modell Explorer

    Acer Nitro 5 AN517-41

    AMD Ryzen 7 5800H with Radeon Graphics

    64 GB RAM, nVidia Geforce RTX3080 Laptop GPU7552

    Windows 11 Home, Version 23H2, Betriebssystembuild 22631.3085

    Windows Defender

    Edited once, last by Schmiermax (February 9, 2024 at 5:42 PM).

  • Hallo Schmiermax

    Ist angekommen, ich frag mal nach

    Freundliche grüße

    Rudi

    Display Spoiler

    EEP 6.1, EEP Modellkonverter

    EEP 13 - 17 mit allen Plugins; HomeNos 17 (alle DEV und User)

    Windows 10 pro, AMD FX 8320E 8 x 2.50GHz, 16 GB Ram, NVidia GTX 960 - Pc - Steam

    Windows 11 Intel i9-11900H; 6 x 2,6 GHz; 32 GB RAM, NVIDIA GForce RTX 3070 - Laptop - Präsentation

    Windows 10 pro, AMD Ryzen 5 2600X, 3,6 GHz, 32 GB Ram, NVidia GeForce RTX 2060 - "Arbeits-Pc"