Lua-Funktionsaufrufe mit Parametern in KPs: Geht nicht? Geht doch!

!!! Please ensure, that your contribution or question is placed into the relevant section !!!
Questions about rolling stock, for example, do not belong in "Questions about the Forum". Following is perhaps the right area where your question will be better looked after:
General questions to EEP , Splines, rolling stock, Structures in EEP, landscape elements, Signalling system and controlling, designers, Europe-wide EEP meetings , Gossip
Your cooperation to keep the forum clear is appreciated.
  • Hallo Benny,


    lass bloß den Fehler drin, das funktioniert so wunderbar. :ae_1:

    MfG. Jörg
    Notebook: i7-6700K, 4[8]x4.0 GHz, 32GB RAM DDR4, NVIDIA GTX 980M 8GB, Windows 10, 64-Bit
    installiert: EEP6.1; EEP14.1 expert Patch2 mit Plugin 1; EEP15.0 Patch3

    Zusatzprogramme: EEP Zug-Explorer, EEP Modell-Explorer, JWGleisEditor, ResourcenSwitcher2

  • * wie einige Leute hier im Forum versehentlich(?) herausgefunden haben, kannst du die Variable Zugnamen auch innerhalb der aufgerufenen Funktion verwenden, ohne sie als Parameter übergeben zu haben. Das geht aber eigentlich nur durch einen "Fehler" in meiner Implementierung, und ist definitiv nicht so gedacht.

    Ich habe es vor kurzem herausgefunden, dass der Parameter "Zugname" nur angegeben werden muss, wenn keine weiteren Parameter der Funktion übergeben werden muss.


    Sind mehrere Parameter erforderlich, so kann man den Parameter "Zugname" weglassen und die Variable "Zugname" ist in der Funktion trotzdem verfügbar.