Posts by schlingo

    solltest du oder ein Mitleser in dem Thema "Wünsche für EEP 17und folgende Versionen" EEPDefineRoute und EEPDeleteRoute als neue EEP spezifische Lua-Funktionen vorschlagen.

    Hallo :)


    besser geeignet wäre dafür der EEP Bugtracker, der entgegen dem Namen auch für Wünsche (Feature-Requests) genutzt werden kann (und auch sollte).

    Im Bugtracker kann man auch Feature-Wünsche eintragen und das sollte man auch tun, da sie dort von den Entwicklern am ehesten registriert werden. Insofern und deswegen ist der Bugtracker der "direkte Draht" zu den Entwicklern, ganz im Gegensatz zu irgendwelchen Wunschthreads mit Tausenden von Einträgen. Wenn die Entwickler da mitlesen würden, müssten sie ihre eigentliche Tätigkeit einstellen. Die geringe Mühe eines Eintrages im Bugtracker ist bei alledem nur ein Filter für allzu banale Wünsche. Man muss seinen eigenen Wunsch schon ernst nehmen, um sich diese "Mühe" zu machen.

    Gruß Ingo

    kann es sein, daß Du den Code von Benny nicht verwendet hast?

    Hallo Reinhold :)


    damit hat es überhaupt nichts zu tun.

    Als Ergebnis kommt folgendes:

    Darin vermisse ich aber die print-Zeile 12. Zumindest in Deinem Screenshot ist diese Ausgabe nicht enthalten, was bedeuten würde, dass die Funktion in Zeile 10 nicht true, sondern false liefert. Und genau darum ging es, denn...

    EEPSetTrainRoute gibt wiederum false zurück, weil die neue Route nicht in EEP definiert ist und es erfolgt kein weiterer Ausdruck.

    Gruß Ingo

    Wenn ich in dem Fenster "Suchen" Klicke, werde ich auf die Shopseite geleitet.

    Hallo :)


    das sollte aber nicht so sein, sondern Dir sollte eine HTML-Seite ähnlich...



    ...angezeigt werden, die Du auch in Deinem Ressourcen-Ordner im Unterordner MissingModels findest. Dort kannst Du die fehlenden Modelle kopieren und wie oben beschrieben hier einfügen.

    Bin am Überlegen, ob ich neu Installiere...

    Versuche es vorher mal mit einem Modellscan. Lösche dazu am besten vorher die Datei models.db, dann wird der Modellbestand komplett neu aufgebaut. Achtung! Dabei gehen evtl. selbst definierte Kategorien verloren.


    Gruß Ingo

    Obwohl das ok gegenben wird, also true , wird die Umbenennung nicht gemacht.

    Hallo Reinhold :)


    das Problem haben wir ja dank dem kaffeschluerfer erkannt. Danke dafür :be_1:Nach meinem Verständnis dürfe die Funktion EEPSetTrainRoute in diesem Fall aber kein true zurückgeben. Denn in der Beschreibung heißt es:

    Lua Handbuch wrote:

    Rückgabewert ist entweder true, wenn der angesprochene Zug und die gewünschte Route existieren, sonst false.

    Bist Du sicher, dass das print in Zeile 13 ausgeführt wird?

    In der Beschreibung des Lua-Handbuches müßte als Ergänzung stehen:
    Das zweite Argument ist eine existierende Route als String. oder eine Variable der existierenden Route.

    Danke für den konstruktiven Vorschlag :be_1:Ich habe das mal weitergegeben.


    Gruß Ingo

    Da ist wohl ein Fehler in der Dateiendung: vor dem "3dm" fehl der Punkt.

    Wie kann ich das ändern?

    Hallo :)


    hm, ein seltsames Problem, das ich mir nicht erklären kann. Kannst Du mal auf Suchen klicken, damit die HTML-Datei mit den fehlenden Modellen erstellt wird. Kopiere dann die Modellnamen (inkl. Pfad) und füge sie hier als Codeblock ein. Das sieht dann in etwa wie folgt aus:

    Die falschen Dateinamen müssten ja in der ANL3-Datei stehen. Traust Du Dir zu, diese zu bearbeiten? Ich wüsste nicht, wie das sonst zu lösen wäre. Bitte vorher unbedingt an ein Backup denken. Evtl. kann auch volker53 helfen?


    Gruß Ingo

    falls etwas dabei herauskommt das dann hier veröffentlichen

    Hallo zusammen :)


    nach einem Skype-Chat mit Jörg darf ich sagen, dass es sich tatsächlich um die o.a. Spline-ID handelt. Da Nicci 53 und ich den Absturz nicht reproduzieren können (bei uns funktioniert das Löschen und anschließende Speichern problemlos), kann es sich nicht um einen Fehler in der Anlage handeln, sondern müsste irgendwo im System von Jörg zu finden sein.


    Jörg, ich würde dann dieses Thema auf gelöst setzen. Einverstanden?


    Gruß Ingo

    In der Kategorie "Blauer Würfel" können die Modelle aller Kategorien markiert und kopiert werden (außer Rollmaterial glaube ich).

    Hallo Paul :)


    ergänzend zu DH1 : in 3D kannst Du alles, inklusive Signale und Rollmaterial kopieren und verschieben. Eine feine Sache, die ich gerne nutze.


    Gruß Ingo

    habe ich [...] die RESTORO -Software von Microsoft herunterheladen und agieren lassen

    Hallo Rainer :)


    warum machst Du so etwas und installierst Dir ungefragt solchen Mist? Wer hat Dir so etwas geraten? Warum beantwortest Du nicht einfach unsere Fragen und hältst Dich an unsere Tipps? Der Mist ist übrigens nicht von Microsoft, ganz im Gegenteil raten die völlig zu Recht von so etwas ab. Lies dazu die Microsoft-Supportrichtlinie für die Verwendung von Dienstprogrammen zur Bereinigung der Registrierung.

    nachdem aufgrund der Restoro-Installation eine Security-Firma bei diesem Rechner eine Fernwartung angeboten und gemacht hat und mir für 400 € eine Überarbeitung des Systems angeboten hatte - plus ein 5 Jahres-Wartungsvertrag

    Das macht Dich überhaupt nicht stutzig?

    Durch einen Link von Schlingo (Screen-Shots reiche ich nach) in diesem Thread bin ich erst darauf gestoßen.

    Welcher von meinen Links war das? Ich müsste mir auf die Zunge beißen, auf solche unseriöse Seiten zu verweisen, die solchen Mist empfehlen.

    ich bin, was Computer - Internes angeht, absoluter Laie.

    Dann solltest Du auf solchen Mist wie (vorgebliche) Sicherheits- und Tuningtools verzichten. Die helfen Dir nicht, sondern machen Dir eher Dein System kaputt. Lies dazu Tuning-Tools, die Plage des 21. Jahrhunderts?

    zu Restoro: Vorsicht !

    Dem kann ich mich nur anschließen. Durch diesen Mist ist Dein System kompromittiert. Für mich gibt es da nur eine einzige Lösung, und zwar eine komplette Neuinstallation von Windows.


    Gruß Ingo

    Hallo Jörg Wahrener :)


    danke für die Anlage. Ich habe jetzt einmal ein wenig getestet. Geht es um die Spline-ID 840 !V7 Beton2 Schw A LW1, auf den die Kamera gerichtet ist? Diesen Spline kann ich hier problemlos löschen und dann die Anlage erfolgreich und ohne Absturz speichern.


    Ich kann den Absturz beim Speichern allerdings reproduzieren, wenn ich nicht diesen einen Spline, sondern alle Splines eines Layers auf einmal lösche und dann nur die Splines speichere. Bei mir wird dabei aber ein Errorlog erstellt, z.B.

    Die Angabe unter LastLoad wechselt dabei. Interessant ist offenbar die Angabe Delete Resourcen\Dummies\Track.3dm eine Zeile darüber, sowie die letzte Zeile, die für mich darauf hindeutet, dass auf einen undefinierten Speicherbereich zugegriffen werden soll. Diese Angabe ist immer gleich. Offenbar geht es um einen Spline, den ich nicht besitze.

    Error log gibt es keines

    Ganz sicher nicht? Du hast in Deinem EEP-Ordner keine Datei EEP16_ErrorLog.txt mit Inhalt in etwa wie oben? Die wäre wichtig, um den Spline zu identifizieren.

    Falls Fragen sind können wir die über PM oder skype klären.

    Meine Skype-ID findest Du in meinem Profil.


    Gruß Ingo

    Kann ich das selbst beheben oder da muß sicherlich der Support ran, oder?

    Hallo Rainer :)


    der Support ist sicher immer eine gute Anlaufstelle.


    Was ich dazu aber schon sagen kann: der Fehlercode 0xc0000005 bedeutet "Zugriff verweigert". Erster Verdacht: oben kam ja schon einmal die Frage zu Deinem Virenscanner, die Du offenbar falsch verstanden hast. Deshalb ganz konkret: welche Sicherheits- und/oder Tuningtools sind im Einsatz? Besteht das Problem auch nach einem sauberen Systemstart?


    Gruß Ingo

    Es ist doch nun wirklich nicht so, als ob jeder über die entsprechenden Fertigkeiten verfügen würde um selbst zu bauen.

    Hallo Erik :)


    das habe ich auch nirgends behauptet. Insbesondere scheinen ja Rollmaterialien mit solchen Eigenschaften auch nicht zu den leichteren Projekten zu zählen. Aber Du hast mich unvollständig zitiert. Ich habe auf die Frage...

    Kann man nicht die anderen Fähren auch so bearbeiten?

    ...mit einer Alternative geantwortet. Einerseits können bestehende Modelle (durch den Konstrukteur) geändert werden. Andererseits kann ein neues Modell erstellt werden. Letzteres kann entweder ein Konstrukteur oder der Benutzer selbst, wenn er die Fähigkeiten dazu hat.


    Gruß Ingo

    danach geht's nicht weiter

    Hallo Rainer :)


    was heißt das genau? Bleibt der Startbildschirm stehen oder beendet sich EEP sofort wieder? Stehen Hinweise in der Ereignisanzeige (habe ich hier gerade beschrieben).


    Du weißt übrigens schon, dass Du Dich einfach an ein gelöstes Thema gehängt hast? Wenn Du exakt dasselbe Problem hast, müsste Dir auch die vorgestellte Lösung helfen. Mit anderen Worten: es wäre besser gewesen, wenn auch Du für Dein Problem ein neues Thema eröffnet hättest.


    Gruß Ingo

    I never got a question of preferred language

    Hi Wijnand :)


    you should have got such a choice during installation.

    what can I do to set it to German. There seems to be no switch/setting with wich to control program language.

    That's true. After installation there is no chance to change the GUI language. You will have to un- and reinstall.


    Regards Ingo

    Kann man nicht die anderen Fähren auch so bearbeiten?

    Hallo :)


    ja, grundsätzlich kann "man" das. Ein bestehendes Modell könnte allerdings nur der jeweilige Konstrukteur ändern. Alternativ kannst Du Dir eine solche Fähre mit dem HomeNOS selbst bauen oder Du findest einen Konstrukteur, der das übernimmt.


    Gruß Ingo

    Der Verursacher wurde recht schnell gefunden: ein Gleisspline.

    Hallo Jörg :)


    welcher Spline ist das denn? Ich würde das gerne reproduzieren. Oder ist das eine spezielle Situation in Deiner Anlage?

    Wenn aber das Problem für Entwickler oder so interessant ist stelle ich diesen gerne die Anlagendatei zur Verfügung.

    Ich bin zwar kein Entwickler. Aber für mich ist jeder Fehler (Bug) so wichtig, dass er möglichst gefixt werden sollte. Weißt Du, wo Du die Anlage hinschicken kannst? Falls ja, denke daran, falls vorhanden die beiden ErrorLog-Dateien mitzuschicken. Die enthalten für die Entwickler wichtige Informationen über den Absturz.


    Gruß Ingo